Bug 128530 - (Korean Version Only) Two icons have reversed each other.
Summary: (Korean Version Only) Two icons have reversed each other.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre Icon-Theme-KarasaJaga
  Show dependency treegraph
 
Reported: 2019-11-01 10:42 UTC by scripct1111
Modified: 2019-11-09 07:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Two icons are reversed each other. (7.24 KB, image/png)
2019-11-01 10:44 UTC, scripct1111
Details
The default toolbars of a fresh install, including the two buttons mentioned in the report (21.25 KB, image/png)
2019-11-04 00:56 UTC, Ming Hua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description scripct1111 2019-11-01 10:42:24 UTC
Description:
버그라고 부르기 애매한데, 실수인 건 명확한 것 같습니다.
한국어판에서 "오름차순/내림차순 정렬" 아이콘이 서로 뒤바뀌었습니다.

작업 과정에서 치명적인 실수를 유발할 것 같으니 가능한 빨리 해결해 주셨으면 합니다.

It's ambiguous whether to call it a bug, but what seems to be a mistake is clear.
They have reversed each other which the icons of "Sort Descending / Sort Ascending" in Korean Version.

I'd like you to resolve this as soon as possible, as this could lead to a fatal mistake.

Actual Results:
They have reversed each other which the icons of "Sort Descending / Sort Ascending" in Korean Version.

Expected Results:
It can make a fatal mistake when working.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: ko
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 scripct1111 2019-11-01 10:44:22 UTC
Created attachment 155443 [details]
Two icons are reversed each other.
Comment 2 Julien Nabet 2019-11-01 21:53:56 UTC
On pc Debian x86-64 with master sources updated today, when launching Calc, I don't reproduce this.
Could you give a minimal step by step process to reproduce this?
Perhaps I just missed it.
Comment 3 scripct1111 2019-11-03 04:49:54 UTC
(In reply to Julien Nabet from comment #2)
> On pc Debian x86-64 with master sources updated today, when launching Calc,
> I don't reproduce this.
> Could you give a minimal step by step process to reproduce this?
> Perhaps I just missed it.

한글을 아신다면, 아니 한글을 몰라도 괜찮은 문제입니다.
간단히 생각하세요. 그저 아이콘 위치만 서로 바꾸시면 됩니다.

If you know Hangul... oh, it doesn't matter if you don't know what is Hangul.
Keep it simple. Just switch the positions of the icons with each other.

More information for you:
Look at the image Attached.
You can see the symbols "ㄱ" and "ㅎ".

"ㄱ" is "A" and "ㅎ" is "Z" in the Korean alphabet.

The problem what I requested is "ㄱ" goes to the top if I click the left one. Also, if I click the other, "ㅎ" goes to the top.
Comment 4 Ming Hua 2019-11-04 00:56:46 UTC
Created attachment 155491 [details]
The default toolbars of a fresh install, including the two buttons mentioned in the report

I can reproduce in 6.4.0 alpha1 when I set the UI language to Korean:
버전: 6.4.0.0.alpha1 (x64)
빌드 번호: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU 스레드: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI 표현: GL; VCL: win; 
지역 설정: zh-CN (zh_CN); UI-Language: ko-KR
Calc: CL

Well, reproduce in the sense that I see the two buttons with the icons mentioned in the original report (see attached screenshot), and that the left one is "sort ascending" and the right one is "sort descending" when tested with numbers.

I don't know Korean so can't verify the reporter's claim that they are wrong and should be switched.
Comment 5 Ming Hua 2019-11-04 01:07:32 UTC
The two icons are in:
https://opengrok.libreoffice.org/xref/core/icon-themes/colibre/cmd/ko/
named sc_sortascending.png and sc_sortdescending.png .
Comment 6 scripct1111 2019-11-04 09:24:36 UTC
(In reply to Ming Hua from comment #5)
> The two icons are in:
> https://opengrok.libreoffice.org/xref/core/icon-themes/colibre/cmd/ko/
> named sc_sortascending.png and sc_sortdescending.png .

하이고, 개발자분들, 뭐가 그렇게 심각해요?
한글 몰라도 되고, 컴맹인 저한테 간단한 해결책이 있습니다.

제 말대로 해 주세요.

그냥 두 파일 이름을 서로 바꿔주시기만 하면 됩니다.

Oh, come on, developers, why so serious?
No knowledge of Korean language is required, and I, the computer illiteracy, have a very simple solution.

Please follow me.

JUST SWITCH THEIR FILE NAMES EACH OTHER. THAT'S ALL!
Comment 7 Julien Nabet 2019-11-07 16:08:56 UTC
(In reply to Ming Hua from comment #5)
> The two icons are in:
> https://opengrok.libreoffice.org/xref/core/icon-themes/colibre/cmd/ko/
> named sc_sortascending.png and sc_sortdescending.png .

It seems we've got the same pb at these locations too:
- https://opengrok.libreoffice.org/xref/core/icon-themes/colibre_svg/cmd/ko
- https://opengrok.libreoffice.org/xref/core/icon-themes/karasa_jaga/cmd/ko
- https://opengrok.libreoffice.org/xref/core/icon-themes/karasa_jaga_svg/cmd/ko

So if ok also with these, I can submit a patch for this indeed straightforward renaming

Heiko: thought you might be interested in this one. I don't understand why some other icon-themes than colibre/colibre_svg/karasa_jaga/karasa_jaga_svg:
- don't have sc_sortascending sc_sortdescending in "ko" subdir
- don't even have "ko" subdir in cmd
Should some icon-themes be removed because they're obsolete?
Comment 8 Heiko Tietze 2019-11-08 09:28:19 UTC
(In reply to Julien Nabet from comment #7)
> Heiko: thought you might be interested in this one. I don't understand why
> some other icon-themes than colibre/colibre_svg/karasa_jaga/karasa_jaga_svg:
> - don't have sc_sortascending sc_sortdescending in "ko" subdir
> - don't even have "ko" subdir in cmd
> Should some icon-themes be removed because they're obsolete?

No, these are actively maintained by Rizal and Andreas.
Comment 9 Julien Nabet 2019-11-08 10:08:56 UTC
(In reply to Heiko Tietze from comment #8)
> ...
> No, these are actively maintained by Rizal and Andreas.

Thank you for your feedback.

So I won't touch anything for these ones and I'm just waiting for response about my proposition in comment 7 from scripct1111 or Ming
Comment 10 Ming Hua 2019-11-08 11:19:58 UTC
(In reply to Julien Nabet from comment #9)
> So I won't touch anything for these ones and I'm just waiting for response
> about my proposition in comment 7 from scripct1111 or Ming
As I said in comment 4, I don't know Korean, so I don't really have anything to contribute to the conversation at this moment.

A cursory web search confirms scripct1111's claim that ㄱ to ㅎ is ascending order in Korean alpahbet, so if those four set of icons all look the same (and I trust that you've found them all), I say go ahead and submit the renaming patch.
Comment 11 Julien Nabet 2019-11-08 12:56:52 UTC
(In reply to Ming Hua from comment #10)
> ...
> A cursory web search confirms scripct1111's claim that ㄱ to ㅎ is ascending
> order in Korean alpahbet, so if those four set of icons all look the same
> (and I trust that you've found them all), I say go ahead and submit the
> renaming patch.

Ok, I'll submit a patch after my daytime job.
Of course, if someone wants to do it before, don't hesitate! :-)
Comment 12 Julien Nabet 2019-11-08 18:44:32 UTC
I submitted a patch for review here:
https://gerrit.libreoffice.org/#/c/82320/
Comment 13 Commit Notification 2019-11-08 20:11:16 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7eca2c49baad96e1183de6a96a322f4c22f2f8f5

tdf#128530: Two icons have reversed each other (Korean)

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-11-09 01:34:10 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a79640b30ae08087224931bac832bb2d5c9c542a

Related tdf#128530: Two icons have reversed each other (Korean)

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-11-09 01:41:19 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/2419d5da470cd7837f1afe5687b4f7b42f8ac6e5

tdf#128530: Two icons have reversed each other (Korean)

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-11-09 02:44:48 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/2c050924a620474126d95b89bc84482f19e5882b

Related tdf#128530: Two icons have reversed each other (Korean)

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.