Bug 128579 - Text colours in the left-hand sidebar of Start Center not adjusted for contrast when using a dark theme under GNOME
Summary: Text colours in the left-hand sidebar of Start Center not adjusted for contra...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 139431 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2019-11-04 08:52 UTC by ricky.tigg
Modified: 2021-08-02 15:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
LIbreoffice wizard (60.77 KB, image/png)
2019-11-04 08:54 UTC, ricky.tigg
Details
Application names' characters exhibited in low contrast (78.70 KB, image/png)
2019-11-21 12:56 UTC, ricky.tigg
Details
View of Start Center under same theme in Gnome 3.36.6 (64.61 KB, image/png)
2020-09-23 13:05 UTC, ricky.tigg
Details
screen clip of StartCenter 7.1.0.1 on Windows with GreyEve theme (157.43 KB, image/png)
2021-01-05 20:17 UTC, V Stuart Foote
Details
insert table grid in Adwaita-dark gtk theme (17.61 KB, image/png)
2021-01-06 02:17 UTC, orzun
Details
screenshot of start center in LO 7.3 alpha0+ (37.70 KB, image/png)
2021-08-01 12:41 UTC, stragu
Details
Start Center | Null contrast of some characters and the background (48.25 KB, image/png)
2021-08-02 13:04 UTC, ricky.tigg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ricky.tigg 2019-11-04 08:52:12 UTC
Description:
A text is partially visible.

Steps to Reproduce:
Open Libreoffice wizard.

Actual Results:
Part of characters of *Base Database* have either no contrast with backgrund or are beside a non-transparent element; see libreoffice_wizard_v 6.3.2.2.png.

Expected Results:
To be readable without having focus on it.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.2.2; Build ID: 6.3.2.2-1.fc31; CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US; Calc: threaded
Comment 1 ricky.tigg 2019-11-04 08:54:15 UTC
Created attachment 155494 [details]
LIbreoffice wizard
Comment 2 Timur 2019-11-09 18:47:52 UTC
How do you get that screen "Libreoffice wizard"?
Did you try profile reset? 
What your OpenGL status and did you try to change it?
Maybe not related, but please update to LO 6.3.3.
Comment 3 ricky.tigg 2019-11-11 07:58:02 UTC
Open document, close it – User Profile Reset: yes – OpenGL status: not enabled, not used, not modified.

Version: 6.3.3.2.0+; Build ID: 6.3.3.2-2.fc31; CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US; Calc: threaded
Comment 4 Xisco Faulí 2019-11-11 12:06:05 UTC Comment hidden (obsolete)
Comment 5 ricky.tigg 2019-11-11 13:22:34 UTC Comment hidden (obsolete)
Comment 6 ricky.tigg 2019-11-19 08:48:38 UTC Comment hidden (obsolete)
Comment 7 ricky.tigg 2019-11-19 12:33:03 UTC
Issue observed in Version: 6.4.0.0.alpha1+; Build ID: 80109586e6cb6d3e2e0a53a9079c3125ec9b8368; CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-01_23:56:52; Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US; Calc: threaded.
Comment 8 ricky.tigg 2019-11-21 12:56:12 UTC
Created attachment 156000 [details]
Application names' characters exhibited in low contrast

Issue, which was observable in full screen mode, is no longer observable in Version: 6.3.3.2.0+; Build ID: 6.3.3.2-2.fc31; CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US; Calc: threaded.

Issue is though yet observable when window is reduced according to its vertical axis; see libreoffice_wizard_v 6.3.3.2.0+.png.
Comment 9 Buovjaga 2020-04-26 15:49:18 UTC
So this only happens with a dark theme?
Comment 10 Timur 2020-09-18 06:42:45 UTC
Please respond and test master LO from https://dev-builds.libreoffice.org/daily/master/current.html or sometimes older https://dev-builds.libreoffice.org/daily/master/current.html.
Comment 11 ricky.tigg 2020-09-23 09:24:05 UTC
Think "Help us to help us"; you then need to provide a proper link; a one to portable file. Otherwise your "please" are no help.
Comment 12 Buovjaga 2020-09-23 09:39:01 UTC
(In reply to ricky.tigg from comment #11)
> Think "Help us to help us"; you then need to provide a proper link; a one to
> portable file. Otherwise your "please" are no help.

Simple portables: https://libreoffice.soluzioniopen.com/
I also created instructions that you can use to easily create your own portable appimage files: https://wiki.documentfoundation.org/Installing_in_parallel/Linux#Automated_installation
Comment 13 ricky.tigg 2020-09-23 13:05:32 UTC
Created attachment 165796 [details]
View of Start Center under same theme in Gnome 3.36.6

Build: https://gerrit.libreoffice.org/gitweb?p=core.git;a=log;h=40f42f317757ef02d0a4d1cfd1c4f5bd8583e8e0
Comment 14 Buovjaga 2020-09-23 13:32:50 UTC
I can't test, because I don't have GNOME and for some reason a dark theme under KDE Plasma has no effect on the left-hand sidebar of Start Center
Comment 15 Ming Hua 2021-01-05 17:58:37 UTC
*** Bug 139431 has been marked as a duplicate of this bug. ***
Comment 16 V Stuart Foote 2021-01-05 20:17:37 UTC
Created attachment 168709 [details]
screen clip of StartCenter 7.1.0.1 on Windows  with GreyEve theme

Can not confirm on Windows builds with GreyEve (a11y theme)

Version: 7.1.0.1 (x64)
Build ID: b585d7d90ab863bf29b2d110c174c0c2a98f3ee4
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 17 orzun 2021-01-06 02:17:29 UTC
Created attachment 168716 [details]
insert table grid in Adwaita-dark gtk theme

Also, it happens to `insert table` grid of Libreoffice Writer.
Comment 18 stragu 2021-08-01 12:41:29 UTC
Created attachment 174013 [details]
screenshot of start center in LO 7.3 alpha0+

I could not reproduce with a recent daily build of master, on Ubuntu 20.04, GNOME 3.36 with dark theme on:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 1dd4a80fa076bedb3a82821517036bad8dd79857
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-07-26_22:41:19
Calc: threaded

The contrast issue in the table tooltip described by orzun in comment 17 should be reported separately, to make sure we focus on specific issues.
Comment 19 ricky.tigg 2021-08-02 13:04:20 UTC
Created attachment 174028 [details]
Start Center | Null contrast of some characters and the background

Version: 7.1.5.2; Build ID: 10(Build:2); CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3; Locale: fi-FI (fi_FI.UTF-8); UI: fi-FI; Calc: threaded

On that partial snapshot from an English locale system all looks fine. Here  is a complete snapshot LO_7.1.5.2_ Start Center_Finnish_locale.png in the above mentionned locale; at the bottom of the pillar you can  observe "Libre" alone which then illustrates a partial display due to null contrast of some characters and the background.
Comment 20 Buovjaga 2021-08-02 15:24:51 UTC
(In reply to ricky.tigg from comment #19)
> Created attachment 174028 [details]
> Start Center | Null contrast of some characters and the background
> 
> Version: 7.1.5.2; Build ID: 10(Build:2); CPU threads: 4; OS: Linux 5.13; UI
> render: default; VCL: gtk3; Locale: fi-FI (fi_FI.UTF-8); UI: fi-FI; Calc:
> threaded
> 
> On that partial snapshot from an English locale system all looks fine. Here 
> is a complete snapshot LO_7.1.5.2_ Start Center_Finnish_locale.png in the
> above mentionned locale; at the bottom of the pillar you can  observe
> "Libre" alone which then illustrates a partial display due to null contrast
> of some characters and the background.

stragu reported it as bug 143673 yesterday, I will bibisect it