Download it now!
Bug 128611 - FILEOPEN RTF: Rotated text isn't displayed correctly in a table
Summary: FILEOPEN RTF: Rotated text isn't displayed correctly in a table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.5
Keywords:
Depends on:
Blocks: RTF-Tables
  Show dependency treegraph
 
Reported: 2019-11-05 15:56 UTC by Ladislav Nesnera
Modified: 2019-12-06 07:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LIBRE-2019_vzor_narození.rtf (48.79 KB, application/rtf)
2019-11-05 15:57 UTC, Ladislav Nesnera
Details
WORD-2019_vzor_narozeni.rtf (119.09 KB, application/rtf)
2019-11-05 15:58 UTC, Ladislav Nesnera
Details
02_matrika_vera_rozdily_cervene.PNG (133.81 KB, image/png)
2019-11-05 15:59 UTC, Ladislav Nesnera
Details
03_matrika_vera_verze_SW.PNG (199.87 KB, image/png)
2019-11-05 15:59 UTC, Ladislav Nesnera
Details
Error vertical text in template rtf (181.11 KB, image/png)
2019-11-11 17:53 UTC, IT department of City Nove Mesto na Morave
Details
Flipped line (new LO behavior). (110.04 KB, image/png)
2019-12-05 10:51 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ladislav Nesnera 2019-11-05 15:56:45 UTC
Description:
RTF file generated by SW for registry office looks different in Writer and Word

Steps to Reproduce:
1. generete print output by VERA Matrika (SW for registry office) when Writer | Word is set as default text editor
2. compare save results Writer/Word

Actual Results:
Have a look at "02_matrika_vera_rozdily_cervene.PNG" when red highlighted is incorrect


Expected Results:
left side in "02_matrika_vera_rozdily_cervene.PNG" is correct


Reproducible: Always


User Profile Reset: No



Additional Info:
LIBRE-2019_vzor_narození.rtf - RTF generated by Writer
WORD-2019_vzor_narozeni.rtf - RTF generated by Word

Writer 2007 - for more look at 03_matrika_vera_verze _SW.PNG
Comment 1 Ladislav Nesnera 2019-11-05 15:57:59 UTC
Created attachment 155537 [details]
LIBRE-2019_vzor_narození.rtf
Comment 2 Ladislav Nesnera 2019-11-05 15:58:40 UTC
Created attachment 155538 [details]
WORD-2019_vzor_narozeni.rtf
Comment 3 Ladislav Nesnera 2019-11-05 15:59:11 UTC
Created attachment 155539 [details]
02_matrika_vera_rozdily_cervene.PNG
Comment 4 Ladislav Nesnera 2019-11-05 15:59:51 UTC
Created attachment 155540 [details]
03_matrika_vera_verze_SW.PNG
Comment 5 Ladislav Nesnera 2019-11-05 16:02:06 UTC
This article could be related - https://vmiklos.hu/blog/hackweek-2019.html
Comment 6 Dieter Praas 2019-11-06 07:52:58 UTC
Ladislav, thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 7 IT department of City Nove Mesto na Morave 2019-11-11 17:53:17 UTC
Created attachment 155713 [details]
Error vertical text in template rtf

Hi Dieter,
a colleague has installed, according to your notice the latest version 6.3.3.2 (x64). The error repeats as shown in the file.
Zbynek Grepl , CIO
CiTY of Nove Mesto na MOrave
Comment 8 Dieter Praas 2019-11-11 18:49:28 UTC
I tested with attachment 155537 [details]. Strikethroug looks the same to me in LO Writer and MS word, but I confirm that rotated text isn't displayed correctly.

Version: 6.4.0.0.alpha1 (x64)
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Every bug report should only be about one issue. So if you still see differnet view in strikethrough of the cell, please file an new bug report.
Comment 9 Xisco Faulí 2019-11-27 17:03:54 UTC
The wrong line orientation is also reproducible in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 10 Commit Notification 2019-11-27 21:00:22 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f9f421b7beaf117968c0dbfd84a2dad3dc85136a

Related: tdf#128611 RTF import: handle vertical flip of line shapes

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-12-02 13:51:19 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5ce09e923a5419acb6700cea055f9d350e8f0e51

Related: tdf#128611 RTF import: handle vertical flip of line shapes

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-12-03 10:06:10 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/888498cfc8822401d79d8a5e56e1bf502172eff7

Related: tdf#128611 RTF import: handle vertical flip of line shapes

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-12-04 19:23:13 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0fa95852b0968fa2a35efb8ca816949c58af56e0

tdf#128611 sw: improve rotated text layout in table cells

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Miklos Vajna 2019-12-05 08:23:51 UTC
I think this is now fixed on master.
Comment 15 Xisco Faulí 2019-12-05 10:10:22 UTC
I do confirm the vertical text in the first columns i fixed in

Version: 6.5.0.0.alpha0+
Build ID: 304368c7be2c9e408cc3884183e39d90a4b15da7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue.

Meanwhile, the problem with the rotated line is still reproducible.
@Ladislav Nesnera, would you mind reporting it in a follow-up bug ?
Comment 16 Miklos Vajna 2019-12-05 10:50:26 UTC
Xisco: can you please post a screenshot what do you see? See attachment 155540 [details] on how this used to look like (Word, old LO) and the first commit related to this bug fixes the missing vertical flip.
Comment 17 Miklos Vajna 2019-12-05 10:51:51 UTC
Created attachment 156324 [details]
Flipped line (new LO behavior).

This is how it looks like for me now (good).
Comment 18 Xisco Faulí 2019-12-05 11:09:19 UTC
(In reply to Miklos Vajna from comment #16)
> Xisco: can you please post a screenshot what do you see? See attachment
> 155540 [details] on how this used to look like (Word, old LO) and the first
> commit related to this bug fixes the missing vertical flip.

Hi Miklos,
I've just realized I was using 'LIBRE-2019_vzor_narození.rtf' file for testing it instead of 'WORD-2019_vzor_narozeni.rtf'
I do confirm the vertical line is also fixed in

Version: 6.5.0.0.alpha0+
Build ID: 304368c7be2c9e408cc3884183e39d90a4b15da7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 19 Commit Notification 2019-12-05 11:20:33 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5e709d4d665fa14aed4e686080e4eda797440d36

tdf#128611 sw: improve rotated text layout in table cells

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2019-12-06 07:59:26 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/cfbe24058485f87af5a0044c33cd4af29963cb94

tdf#128611 sw: improve rotated text layout in table cells

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.