Download it now!
Bug 128626 - STATUSBAR: Wrong page number after page break with renumbering
Summary: STATUSBAR: Wrong page number after page break with renumbering
Status: CLOSED DUPLICATE of bug 117231
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 130490 (view as bug list)
Depends on:
Blocks: Statusbar
  Show dependency treegraph
 
Reported: 2019-11-06 11:59 UTC by Vito Caleandro
Modified: 2020-03-02 16:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (87.75 KB, application/pdf)
2019-11-06 12:01 UTC, Vito Caleandro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vito Caleandro 2019-11-06 11:59:33 UTC
Description:
Example: After inserting a manual page break in first page, with restart page option at value 1, the second page shows page numbrer = 3 instead of 2.

Steps to Reproduce:
1.Create a new writer document
2.Insert a page break setting next page format to "Predefined" and set start page number to 1 
3.observe page number of new page (in status bar and in total page number) and see it is 3 and not 2! (while the page number shown between parenthesis is right).

Actual Results:
Phisical page numbering seems wrong.

Expected Results:
It should be: "2 of 2 (Page number 1)"


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Vito Caleandro 2019-11-06 12:01:23 UTC
Created attachment 155573 [details]
screenshot
Comment 2 Dieter 2019-11-06 12:36:17 UTC
This behaviour was discussed in a previous bug, but I couldn't find it. 'As far as I remember, the basic idea is that - if you have a book - odd page numbers are always on the first page of a sheet. This is why you have three pages, but page two (backside of the first papersheet) isn't displayed.
Comment 3 Heiko Tietze 2019-11-06 16:41:18 UTC
(In reply to Dieter Praas from comment #2)
> This behaviour was discussed in a previous bug, but I couldn't find it.

Bug 117231?
Comment 4 Dieter 2019-11-06 18:09:51 UTC
(In reply to Heiko Tietze from comment #3)
> (In reply to Dieter Praas from comment #2)
> > This behaviour was discussed in a previous bug, but I couldn't find it.
> 
> Bug 117231?

Yes!!!!

Vito, if you change to book view, you see the blank page. Please also read the informations there about how to deal with page breaks.
Comment 5 sagarikanev 2019-11-07 10:44:08 UTC Comment hidden (spam)
Comment 6 Heiko Tietze 2019-11-07 11:00:03 UTC

*** This bug has been marked as a duplicate of bug 117231 ***
Comment 7 Dieter 2020-02-06 18:25:25 UTC
*** Bug 130490 has been marked as a duplicate of this bug. ***
Comment 8 mouad 2020-03-02 15:35:48 UTC Comment hidden (spam)
Comment 9 mouad 2020-03-02 15:38:32 UTC Comment hidden (spam)