Bug 128641 - The English characters are recognized as Asian characters unless a line is broken.
Summary: The English characters are recognized as Asian characters unless a line is br...
Status: RESOLVED DUPLICATE of bug 126248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-07 01:12 UTC by Slashy
Modified: 2019-11-07 16:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Slashy 2019-11-07 01:12:34 UTC
Description:
https://ask.libreoffice.org/en/question/211548/the-english-characters-are-recognized-as-asian-characters-unless-a-line-is-broken/

Steps to Reproduce:
1.Set the different fonts for Western characters and Asian characters 

Actual Results:
English characters are recognized as Asian characters, thus English gets Asian font, unless at least one line is broken within a cell.

Expected Results:
Both Western and Asian characters get corresponding fonts properly regardless of whether at least one line is broken within a cell.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Info from "Help - About LibreOffice": https://i.imgur.com/r01OF27.png

I have no idea what Hardware I should select but the Processor my PC have is Intel(R) Core(TM) i5-2500k CPU @ 3.30GHz 3.30 GHz; of course it is x64 based Processor.

When I tried in Safe Mode, it gave me a different result surprisely, like it sometimes give characters proper fonts for one line cells, though the glitch itself is still occuring.
Result video: https://i.imgur.com/HRrce4V.gifv
Sample I used: https://ask.libreoffice.org/upfiles/1570338719562422.ods

When I tired in normal mode right after that, it doesn't reproduce the results what I've gotten from Safe Mode, just as same as what happening in the link.
Comment 1 Slashy 2019-11-07 03:18:10 UTC
+ I found out that switching the "Automatic Spell Checking" does something interesting when I was reproducing the glitch in a completely new sheet just for a case of which I thought it could reproduce things that might be different with what I caused in the attached sheet, although the attached sheet does same thing with the said new sheet: https://i.imgur.com/c0ZPt7L.png
Comment 2 Ming Hua 2019-11-07 16:21:49 UTC
I believe this is the same bug as the one I reported in bug 126248.
Comment 3 Slashy 2019-11-07 16:37:58 UTC
(In reply to Ming Hua from comment #2)
> I believe this is the same bug as the one I reported in bug 126248.

I didn't notice that it was already reported.. I see both bug reports are about the identical bug I guess.
Given this, I wouldn't mind if this bug report got closed or anything else.
Comment 4 Ming Hua 2019-11-07 16:43:42 UTC
(In reply to Slashy from comment #3)
> (In reply to Ming Hua from comment #2)
> > I believe this is the same bug as the one I reported in bug 126248.
> 
> I didn't notice that it was already reported.. I see both bug reports are
> about the identical bug I guess.
> Given this, I wouldn't mind if this bug report got closed or anything else.
That's alright, I'm just glad someone else is reporting the same problem I was having.

Since my bug contains more infomration (Kunlong's bibisect work and so on), I'll mark your bug as a duplicate.

*** This bug has been marked as a duplicate of bug 126248 ***