Bug 128689 - Request to Localize More Formatting Icons into Korean UI
Summary: Request to Localize More Formatting Icons into Korean UI
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.4 target:6.4....
Keywords:
Depends on: CJK-Korean
Blocks: Icon-Theme-Breeze Icon-Theme-KarasaJaga Icon-Theme-Elementary Icon-Request Icon-Theme-Sifr
  Show dependency treegraph
 
Reported: 2019-11-09 21:13 UTC by Rizal Muttaqin
Modified: 2020-06-29 06:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
elementary icons with Korean UI are not fully localized (2.87 MB, image/png)
2019-11-09 21:13 UTC, Rizal Muttaqin
Details
Colibre and elementary View Data Source still using international icons (214.98 KB, image/png)
2019-11-10 12:51 UTC, Rizal Muttaqin
Details
Sifr and Breeze are now fully localized for Korean UI (99.07 KB, image/png)
2020-04-19 08:50 UTC, Rizal Muttaqin
Details
MS Word 2016's Korean Vertical & horizontal Text setting UI (74.14 KB, image/png)
2020-04-30 06:44 UTC, DaeHyun Sung
Details
HWP 2018's Korean Vertical & horizontal Text setting UI (295.21 KB, image/png)
2020-04-30 06:45 UTC, DaeHyun Sung
Details
HWP 2018's Korean Vertical & horizontal Text setting UI (Top Icon Selection) (263.52 KB, image/png)
2020-04-30 06:55 UTC, DaeHyun Sung
Details
Vertical Text setting Screenshot on HWP2010 (Korean word processor) (271.30 KB, image/png)
2020-05-02 18:03 UTC, DaeHyun Sung
Details
Korean Vertical & Horizontal text setting on HWP 2018 screenshot (46.48 KB, image/png)
2020-05-02 18:05 UTC, DaeHyun Sung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2019-11-09 21:13:40 UTC
Created attachment 155669 [details]
elementary icons with Korean UI are not fully localized

Step to reproduce:

1. Create a new Writer document
2. Set language interface to Korean (Rok)

Actual Result:

Some icons still using international version

Expected Result:
More icons localized into Korean
Comment 1 Commit Notification 2019-11-10 08:30:35 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d23679fce47d96cf19d7ebf8a7338ba68d6bc7a1

elementary: Fix for tdf#128689: Add more Korean UI localized icons

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2019-11-10 10:02:14 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/a652b1f2e47bba2ccb6d4dc4cf863ae69b84c83b

elementary: Fix for tdf#128689: Add more Korean UI localized icons

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Rizal Muttaqin 2019-11-10 12:51:54 UTC
Created attachment 155675 [details]
Colibre and elementary View Data Source still using international icons

Sort icons in View > Data sources are still needed to be localized
Comment 4 Commit Notification 2019-11-10 12:53:21 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5ae8f2f07815443716b3066706b4f193fe61f7c9

KJ: tdf#123266,  tdf#127458, tdf#128689

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-11-10 14:04:46 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3b678ab1904188978e3ecdc51e8febc241cf8aa9

tdf#127458 (Colibre), tdf#128689 (Colibre & elementary)

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-11-10 20:41:43 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/42de906c9cba2f78537f935d68cfa6fd86ba5527

tdf#127458 (Colibre), tdf#128689 (Colibre & elementary)

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-11-10 20:42:06 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/eb9821c83020819f5d85e612701fb2f77c532943

KJ: tdf#123266,  tdf#127458, tdf#128689

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Rizal Muttaqin 2019-11-11 04:28:16 UTC
Reopened since Breeze and Sifr have not get the icons.
Comment 9 Commit Notification 2020-04-11 12:45:20 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/4d79a2d8a90715d4ffa4daea31436876c0abbfca

Sifr: Add more Korean UI icons: tdf#128689

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-04-11 15:10:48 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dd1746d608e091e1f3d06a588f689d7047cc6748

Sifr: Add more Korean UI icons: tdf#128689

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-04-14 09:12:35 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a497154dcdefde28a48dbcc25cb34e8043f1827f

Sukapura: tdf#128689: Strikethrough for Korean UI

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-04-14 12:19:22 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5431e8e25c6668480ebac11248f2aecbc0bda431

Sifr: Add Korean UI tdf#128689

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-04-15 09:32:14 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/bda59d0f01c97fa1be2a540ea8632e873706e307

Sifr: Add Korean UI tdf#128689

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-04-15 12:59:32 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b912f850a309779d097901cd592c0fda44b05071

Breeze: Add support for Korean UI tdf#128689

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-04-15 12:59:38 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/708eec22e272427f7373b1379a1ffcdbc19153c9

Breeze: Add support for Korean UI tdf#128689

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Rizal Muttaqin 2020-04-19 08:50:59 UTC
Created attachment 159695 [details]
Sifr and Breeze are now fully localized for Korean UI

Verified fixed in

버전: 7.0.0.0.alpha0+빌드 번호: 1289ef10406e00d0fc9abc5bca444d026ab21743CPU 스레드: 4; OS: Linux 4.20; UI 표현: 기본; VCL: kf5; TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-04-16_09:37:58지역 설정: id-ID (id_ID.UTF-8); UI-Language: ko-KRCalc: threaded
Comment 17 Rizal Muttaqin 2020-04-20 08:41:02 UTC
DaeHyun Sung

May be you are interested with some items in every icon theme and in every size:

- Sort icon in Calc or in Writer's Data Sources (Ctrl + Shift + F4)
- Vertical text (Show Draw Functions)
- Text Direction (activate by enable RTL configuration)
Comment 18 Commit Notification 2020-04-20 11:35:59 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e38c83af70ff1e077d28116702c55cad20cdef2a

Breeze,elementary,KJ,Sifr: Fix for tdf#128689

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-04-20 13:56:08 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/443a4d5fad4835769a2d928f6dd1b8967b01204d

Breeze,elementary,KJ,Sifr: Fix for tdf#128689

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-04-20 13:56:15 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/56774dbd6b36631a63cdb3173574a6eedaec371c

Sukapura: Fix for tdf#128689 Add more Korean icons

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 DaeHyun Sung 2020-04-30 06:37:10 UTC
I found wrong UI for Korean.

Vertical Icon is wrong.
Comment 22 DaeHyun Sung 2020-04-30 06:44:13 UTC
Created attachment 160107 [details]
MS Word 2016's Korean Vertical & horizontal  Text setting UI

MS Word 2016's Korean Vertical & horizontal  Text setting UI
Comment 23 DaeHyun Sung 2020-04-30 06:45:15 UTC
Created attachment 160108 [details]
HWP 2018's Korean Vertical & horizontal  Text setting UI

HWP(Hangul Word Processing) 2018's Korean Vertical & horizontal  Text setting UI
Comment 24 DaeHyun Sung 2020-04-30 06:55:12 UTC
Created attachment 160109 [details]
HWP 2018's Korean Vertical & horizontal Text setting UI (Top Icon Selection)

HWP 2018's Korean Vertical & horizontal Text setting UI (Top Icon Selection)
Comment 25 Rizal Muttaqin 2020-04-30 14:06:25 UTC
(In reply to DaeHyun Sung from comment #21)
> I found wrong UI for Korean.
> 
> Vertical Icon is wrong.

Please give me more details which icons need to be adjusted? Better to give me side by side comparison. Your screenshots are too general and broaden. At least give a rectangular or scribble.
Comment 26 DaeHyun Sung 2020-05-02 16:21:03 UTC
(In reply to Rizal Muttaqin from comment #25)
> (In reply to DaeHyun Sung from comment #21)
> > I found wrong UI for Korean.
> > 
> > Vertical Icon is wrong.
> 
> Please give me more details which icons need to be adjusted? Better to give
> me side by side comparison. Your screenshots are too general and broaden. At
> least give a rectangular or scribble.

Here is example of Korean Vertical text
W3C - Requirements for Hangul Text Layout and Typography  
Writing Direction (Horizontal Writing, Vertical Writing)
https://w3c.github.io/klreq/#para-direction

Unlike Latin-language, Korean alphabet don't rotate 90 degrees to the right in vertical writing.

So, Icon is wrong
Comment 27 DaeHyun Sung 2020-05-02 18:03:44 UTC
Created attachment 160232 [details]
Vertical Text setting Screenshot on HWP2010 (Korean word processor)

Vertical Text setting Screenshot on HWP2010 (Korean word processor)
Comment 28 DaeHyun Sung 2020-05-02 18:05:17 UTC
Created attachment 160233 [details]
Korean Vertical & Horizontal text setting on HWP 2018 screenshot

Korean Vertical & Horizontal text setting on HWP 2018 screenshot
Comment 29 Commit Notification 2020-05-05 17:18:22 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fdaf4761bc106d7443ff95491d759baf4d1804c8

Icons: fix for tdf#128689 wrong Korean vertical text icons

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2020-05-05 22:06:03 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/647fc2a9019f4c771e992ab48c312259ad80f1f9

Sukapura: fix for tdf#128689 wrong Korean vertical text icons

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Commit Notification 2020-05-06 02:36:50 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/ba72a53c8e695d1352329c44d3b4934632025ba0

Icons: fix for tdf#128689 wrong Korean vertical text icons

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 DaeHyun Sung 2020-05-08 13:35:36 UTC
I checked the commit and build it.

It looks good for Korean Vertical text icon.

(In reply to Commit Notification from comment #31)
> Rizal Muttaqin committed a patch related to this issue.
> It has been pushed to "libreoffice-6-4":
> 
> https://git.libreoffice.org/core/commit/
> ba72a53c8e695d1352329c44d3b4934632025ba0
> 
> Icons: fix for tdf#128689 wrong Korean vertical text icons
> 
> It will be available in 6.4.5.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.
Comment 33 Rizal Muttaqin 2020-05-08 13:46:19 UTC
(In reply to DaeHyun Sung from comment #32)
> I checked the commit and build it.
> 
> It looks good for Korean Vertical text icon.
> 

Sorry but actually someone should create a new separate ticket for this bug, not hijacking this one. In the next time ;). Thank you very much
Comment 34 Commit Notification 2020-06-29 06:01:12 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/eb467d73304cc4ddc4b7fcda685ebadf6d4ea8d1

Colibre: tdf#128689, add more Korean UI

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2020-06-29 06:45:01 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/698d2372b707a0429114a4a4ac5c7ec8a5f8e056

Colibre: tdf#128689, add more Korean UI

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.