Download it now!
Bug 128714 - Copy and paste within same document pasting previous buffer entry from Ubuntu 19.10
Summary: Copy and paste within same document pasting previous buffer entry from Ubuntu...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All Linux (All)
: high normal
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
: 128663 128740 129354 130147 130748 132403 133029 135719 (view as bug list)
Depends on:
Blocks: Clipboard
  Show dependency treegraph
 
Reported: 2019-11-11 15:01 UTC by besancon4me
Modified: 2020-09-29 13:08 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description besancon4me 2019-11-11 15:01:32 UTC
This has been happening since the latest release of LibreOffice.
To recreate: 
Create a new Text Document and enter some text and/or images.
Select a line of text and copy and paste it to another part of the same document.
Select another different line of text or an image and copy that.
Paste it into the same document.
Result - the first line of text will be pasted, not the second one.
The copy and paste buffer does not seem to be being cleared properly, or perhaps the copy text is only being written to the buffer AFTER the user has selected 'paste' if there is already something in the buffer.
To get the second line of text or image you will need to repeat the copy and paste action.
Comment 1 V Stuart Foote 2019-11-11 19:18:50 UTC
Internal LibreOffice Clipboard management can be affected by the os/DE in use. Please identify Linux distribution and Desktop environment you are having issue with. 

Also, please clip the contents of the Help -> About dialog and paste.
Comment 2 besancon4me 2019-11-11 21:53:09 UTC
Version: 6.3.2.2
Build ID: 1:6.3.2-0ubuntu2
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Desktop = Gnome
VTE version 5802

5.3.0-19-generic
Comment 3 besancon4me 2019-11-11 21:54:58 UTC
It is also happening with cut and paste as well as copy and paste, but I guess that is to be expected if it is to do with the buffer behaviours.
Comment 4 QA Administrators 2019-11-12 03:34:07 UTC Comment hidden (obsolete)
Comment 5 V Stuart Foote 2019-11-12 19:42:59 UTC Comment hidden (obsolete)
Comment 6 V Stuart Foote 2019-11-12 19:53:02 UTC
dupe bug 128740 -- Ubuntu 19.10 w/gtk3 on 6.3.2.2

=> NEW
Comment 7 Timur 2020-01-24 08:30:49 UTC
*** Bug 130147 has been marked as a duplicate of this bug. ***
Comment 8 Timur 2020-01-24 08:31:57 UTC
*** Bug 129354 has been marked as a duplicate of this bug. ***
Comment 9 Marcello Nuccio 2020-03-25 07:30:38 UTC
I confirm this bug. Tested on two different computers with Ubuntu 19.10 (but I have seen it happening on previous versions too). 

It looks like it is easier to reproduce by using the mouse and the context menu to do the copy and the paste. But it randomly happens when using the keyboard too.

I have not reported it before because I was hoping to find a pattern to reliably reproduce it, but I have not found any. Sorry. However it happens very frequently and it makes Writer almost unusable when editing a document with lots of copied contents.
Comment 10 besancon4me 2020-03-25 08:21:09 UTC Comment hidden (obsolete)
Comment 11 Timur 2020-03-25 15:39:54 UTC
*** Bug 128663 has been marked as a duplicate of this bug. ***
Comment 12 Timur 2020-04-25 18:37:32 UTC
*** Bug 132403 has been marked as a duplicate of this bug. ***
Comment 13 Timur 2020-05-18 11:51:43 UTC
*** Bug 133029 has been marked as a duplicate of this bug. ***
Comment 14 Timur 2020-05-18 12:03:09 UTC
Similar to bug 128803, I'll mark NotOurBug.
Please test with mutter > 3.36.2 version.
Comment 15 Timur 2020-05-18 12:06:55 UTC
*** Bug 132511 has been marked as a duplicate of this bug. ***
Comment 16 Timur 2020-05-18 16:49:16 UTC
*** Bug 130748 has been marked as a duplicate of this bug. ***
Comment 17 tim 2020-05-19 06:24:57 UTC
There is a possible fix for ubuntu 20.04.  See https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1852183 regarding 'mutter'.
Comment 18 BogdanB 2020-08-13 19:33:11 UTC
*** Bug 135719 has been marked as a duplicate of this bug. ***
Comment 19 tim 2020-09-29 12:05:18 UTC
mutter has been fixed in ubuntu focal-proposed, version 3.36.6-1

Seems to work OK for me.