Download it now!
Bug 128743 - Start Center sidebar has unwanted white gradient (GTK3)
Summary: Start Center sidebar has unwanted white gradient (GTK3)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
Depends on:
Blocks: Start-Center GTK3
  Show dependency treegraph
 
Reported: 2019-11-12 12:56 UTC by Rizal Muttaqin
Modified: 2020-09-09 12:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Head to Head Start Center Sidebar with GTK2 and GTK3 Backend (132.15 KB, image/png)
2019-11-12 12:56 UTC, Rizal Muttaqin
Details
Still Exist in GTK3 Backend (37.96 KB, image/png)
2019-12-06 15:05 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2019-11-12 12:56:44 UTC
Created attachment 155739 [details]
Head to Head Start Center Sidebar with GTK2 and GTK3 Backend

When using GTK3 backend, (with all due respect as removal of GTK2 backend) the image atop of <Help> and <Extensions> part in the right-sidebar rendered missplaceably or not well integrated. While this image was taken from icon theme respectivefully (see in icon-themes/<icon>/sfx2/res/startcenter-logo.png.

This issue is not reproducible when using GTK2 backend in previous version (LibreOffice 6.3.x) or QT5 backend

Version: 6.4.0.0.alpha1+
Build ID: 4438e7dcbfd78b117b704fd4d15b2e445c3db0b0
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-10_11:21:37
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded


Version: 6.4.0.0.alpha1+
Build ID: 4438e7dcbfd78b117b704fd4d15b2e445c3db0b0
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: qt5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-10_11:21:37
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-11-27 14:49:23 UTC
I can't reproduce it in

Version: 6.5.0.0.alpha0+
Build ID: 3a6f270edfffb97763927b2732feacedbdac1e80
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
Comment 2 Rizal Muttaqin 2019-11-27 18:55:10 UTC
Still reproducible in master

Version: 6.5.0.0.alpha0+
Build ID: e01df3488abe6d319c6874ca870afb82a3ad9b1e
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-25_14:20:57
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 QA Administrators 2019-11-28 04:09:39 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-11-28 11:36:19 UTC
To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 5 Rizal Muttaqin 2019-12-06 15:05:59 UTC
Created attachment 156362 [details]
Still Exist in GTK3 Backend

I still can reproduce it after deleting user profile directory (~/.config/libreofficedev)

Version: 6.5.0.0.alpha0+
Build ID: e01df3488abe6d319c6874ca870afb82a3ad9b1e
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-25_14:20:57
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 QA Administrators 2019-12-07 03:45:09 UTC Comment hidden (obsolete)
Comment 7 Xavier Van Wijmeersch 2019-12-07 12:01:58 UTC
I can reproduce with

Version: 6.3.3.2
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded

but not with

Version: 6.5.0.0.alpha0+
Build ID: 302f0f948d76a2a7c556ed383e909b36495222ee
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Buovjaga 2019-12-18 19:11:05 UTC
Repro and also confirmed by TheUncleMez on design channel.

Arch Linux 64-bit
Version: 6.5.0.0.alpha0+
Build ID: d988b1539c04b18d5a2793348c158e0e692b4619
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 17 December 2019
Comment 9 Commit Notification 2020-06-06 15:28:14 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c4e441d68b4f964716f4cabf2942d086d2ffcd21

tdf#128743 remove completely Start Center's sidebar motif

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-06-16 12:18:08 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/f10fc1dbb3472abffea3fea8b8f19909f6a06d99

tdf#128743 remove completely Start Center's sidebar motif

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-06-30 12:23:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2017bf06ab758270b2a9eeef5717a34e63e63722

Related: tdf#128743 fix unwanted background color of transparent wallpaper

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.