Download it now!
Bug 128753 - CRASH: Closing LibreOffice after cutting content from document
Summary: CRASH: Closing LibreOffice after cutting content from document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.4.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 128759 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-12 15:46 UTC by Xisco Faulí
Modified: 2019-11-14 12:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (5.44 KB, text/plain)
2019-11-12 21:50 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-11-12 15:46:54 UTC
Steps to reproduce:
1. Open a empty calc file
2. Select some celcs
3. Cut
4. Close LibreOffice

-> Crash

Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: a07c637a0e4fe0ab81db70c69decbc946ad37da9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-11-12 15:47:56 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a8a064d11c05feed83f05b0ce8209f7054afd804

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-11-11 11:08:55 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-11-11 17:24:53 +0100
commit	a8a064d11c05feed83f05b0ce8209f7054afd804 (patch)
tree	3a64572d1d12d64b707c50607056f405c3615fcf
parent	33d966ecc1f9fc44016cdeeed15dbaf6bda68eda (diff)
sc: rowcol: tdf#50916 convert mark data structures

Bisected with: bibisect-linux64-6.4 

Adding Cc: to Noel Grandin
Comment 2 Julien Nabet 2019-11-12 21:50:51 UTC
Created attachment 155761 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got a crash just when selecting then cutting the cells.
Comment 3 Julien Nabet 2019-11-12 22:03:48 UTC
Patch submitted for review here:
https://gerrit.libreoffice.org/#/c/82559/
Comment 4 Xisco Faulí 2019-11-13 00:27:10 UTC
*** Bug 128759 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2019-11-13 05:16:21 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f858cd5e5e9b3f66818868b097bbab107bb57930

Related tdf#128753: fix regression

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-11-13 09:36:54 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: 26b7ff2b6cc4def8ff7b02e223961534ba88e654
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Julien Nabet, thanks for fixing this issue!