Bug 128759 - EDITING: Copying a cell with data crash
Summary: EDITING: Copying a cell with data crash
Status: RESOLVED DUPLICATE of bug 128753
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-12 23:27 UTC by m.a.riosv
Modified: 2019-11-13 00:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample file to reproduce the issue (8.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-11-12 23:28 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2019-11-12 23:27:32 UTC
Description:
Copying a cell with an array crash calc.

Steps to Reproduce:
1. Open attached file
2. Goto to the cell with data, it's a simple array
3. Ctr-C -> calc crash

Actual Results:
Calc craash

Expected Results:
I hope not crash


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
No matter OpengGL state.
No matter multi-threaded state
No matter OpenCL state.
Comment 1 m.a.riosv 2019-11-12 23:28:18 UTC
Created attachment 155763 [details]
Sample file to reproduce the issue
Comment 2 m.a.riosv 2019-11-13 00:25:09 UTC
Worse, copying any cell with something -> crash, so critical

Version: 6.4.0.0.alpha1+ (x64)
Build ID: 11dcd3c742f72dc451aeb36f2c56607c48f477a9
CPU threads: 4; OS: Windows 10.0 Build 19013; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL

It didn't happen with the previous version
Version: 6.4.0.0.alpha1+ (x64)
Build ID: 6ed8c8ab84cc344f5388056da20996dd5266aadf
CPU threads: 4; OS: Windows 10.0 Build 19013; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 3 Xisco Faulí 2019-11-13 00:27:10 UTC
I believe this is a duplicate of bug 128753

*** This bug has been marked as a duplicate of bug 128753 ***