Bug 128797 - FILEOPEN XLSX Detective marks cells invalid if number is stored in text cell
Summary: FILEOPEN XLSX Detective marks cells invalid if number is stored in text cell
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.1.0
Keywords: filter:xlsx
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2019-11-14 11:26 UTC by NISZ LibreOffice Team
Modified: 2020-09-28 10:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel (15.16 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-11-14 11:30 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc (144.45 KB, image/png)
2019-11-14 11:31 UTC, NISZ LibreOffice Team
Details
Comparison file from Calc with similar settings that does not exhibit the problem (12.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-11-14 11:32 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-11-14 11:26:53 UTC
Description:
Attached user made XLXS file contains some numbers stored in text formatted cells.  Some are marked by Excel as number stored as text, some are not.
There is cell validation set up as text length >0 to ensure cells are filled.
When the detective is used to mark invalid data, the numbers that are not stored as text are marked as invalid after file open, but if they are changed in length the detective does not mark them as invalid anymore.


Steps to Reproduce:
1.	Open attached file in Excel and Calc. It contains some numbers in cells formatted as text, and Excel marks A2 and A7 as number stored as text but not the rest.
2.	Choose Tools – Detective – Mark Invalid Data in Calc and Data – Validation – Circle Invalid Data in Excel.


Actual Results:
Excel marks the empty A8 cell as invalid. Calc marks A3-A6 as well, since those are just numbers.
Changing their length and rerunning Mark Invalid Data removes their invalid marking.
This does not happen in an ODS file that contains numbers in text formatted cells.


Expected Results:
Calc should not mark cells A3-A6 after opening the file.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.4.0.0.alpha1+ (x86)
Build ID: 80109586e6cb6d3e2e0a53a9079c3125ec9b8368
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-US (hu_HU); UI-Language: en-US
Calc: CL

Also happens in:
Verzió: 6.0.0.3
Build az.: 64a0f66915f38c6217de274f0aa8e15618924765
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; 
Területi beállítások: hu-HU (hu_HU); Calc: CL

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: hu-HU (hu_HU)

Verzió: 4.0.0.3 (Build az.: 7545bee9c2a0782548772a21bc84a9dcc583b89)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 1 NISZ LibreOffice Team 2019-11-14 11:30:11 UTC
Created attachment 155809 [details]
Example file from Excel
Comment 2 NISZ LibreOffice Team 2019-11-14 11:31:37 UTC
Created attachment 155810 [details]
Screenshot of the original document side by side in Excel and Calc
Comment 3 NISZ LibreOffice Team 2019-11-14 11:32:05 UTC
Created attachment 155811 [details]
Comparison file from Calc with similar settings that does not exhibit the problem
Comment 4 Durgapriyanka 2019-11-15 17:02:33 UTC
Thank you for reporting the bug. I can confirm the bug present in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded


and in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Commit Notification 2020-09-25 17:45:51 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/192235e0b71dd2a75bc7de85fe664bb69283f4a0

tdf#128797 sc: fix invalid detective marks cells

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-09-26 09:31:06 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ebe4bbb25a9bcb4263b079a50d932384c7c7fb3e

Consolidate, factor out common duplicated code, tdf#128797 follow-up

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.