Download it now!
Bug 128845 - EDITING: cannot modify a bibliography entry after creating it
Summary: EDITING: cannot modify a bibliography entry after creating it
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL: https://help.libreoffice.org/6.4/en-U...
Whiteboard: target:6.5.0 target:6.3.5 target:6.4....
Keywords: bibisected, bisected, needUITest, regression
: 127455 128152 128328 128949 129279 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-16 19:14 UTC by aldracu
Modified: 2019-12-10 09:34 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aldracu 2019-11-16 19:14:57 UTC
1. insert bibliography entry, choose "from document content", click "New"
2. fill-in the short name and type
3. click OK then Insert.

Now you have a bibliography entry. If you want to modify it (like fill-in a new field) it doesn't work:
1. right-click on the bibliography entry created above
2. choose "bibliography entry" from the menu
3. click edit and fill-in a new field or modify an already filled-in one.
4. click OK, click Apply.

At this point your modifications should be saved in the entry, but in fact, they are ignored.
Comment 1 aldracu 2019-11-17 17:06:24 UTC
to whomever marked this bug as UNCONFIRMED: do you use LibreOffice? (I assume you use it, otherwise you shouldn't be involved in administrating the bugs.) If yes, can you confirm it or, on the contrary, you can edit a bibliography entry and the  changes are preserved?
Comment 2 Timur 2019-11-17 19:23:38 UTC
Thank you for reporting.
You cannot confirm your own bug, so Unconfirmed was a correction of mistake.
And please do not remove See Also bug. It's somewhat related and useful.

I now confirm with master LO 6.5+. No repro 6.2. Regression from 6.3.
Comment 3 Xisco Faulí 2019-11-20 16:46:54 UTC
Regression introduced by:

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-01-18 15:38:07 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-01-21 07:34:09 +0100
commit	3b16e997f69efe2e3f6cdf64fe8fb2727b6ebaa7 (patch)
tree	a0d65d6b892ea39d0da8992cbab6bda579e19cdf
parent	2af5d6006948890229d9e55feb56e0e849bf857d (diff)
cleanup SwAuthEntry manual ref-counting

Bisected with: bibisect-linux64-6.3

Adding Cc: to Noel Grandin
Comment 4 Xisco Faulí 2019-11-26 12:44:47 UTC
*** Bug 128949 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2019-12-04 08:44:32 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/41b752756e53c4f9c3d08cbce412d1408c5aed2f

tdf#128845 writer, cannot modify a bibliography entry

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-12-04 13:18:38 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 8f7010eb47119a2428b77f5d79fc8577d9914958
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!
Comment 7 Xisco Faulí 2019-12-04 13:21:47 UTC
*** Bug 127455 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-12-04 13:25:12 UTC
*** Bug 128152 has been marked as a duplicate of this bug. ***
Comment 9 Timur 2019-12-04 13:27:24 UTC
Xisco, I assume you also verified all duplicates?
Did you test See ALso bug 128328?
Comment 10 Xisco Faulí 2019-12-04 13:29:12 UTC
*** Bug 128328 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2019-12-04 14:14:56 UTC
*** Bug 128949 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2019-12-04 15:15:54 UTC Comment hidden (obsolete)
Comment 13 Commit Notification 2019-12-04 16:18:53 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/ef571f245ee7402380067e4ed2f8647c4b6cef95

tdf#128845 writer, cannot modify a bibliography entry

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-12-04 17:39:46 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/708688556cf820d8fda2e9bc7a6b7d098b76738a

tdf#128845 writer, cannot modify a bibliography entry

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-12-04 17:51:07 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-4":

https://git.libreoffice.org/core/commit/b2149b8b43f6c5c8aaf085e1fd1d179353d7298b

tdf#128845 writer, cannot modify a bibliography entry

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Timur 2019-12-10 09:34:24 UTC
*** Bug 129279 has been marked as a duplicate of this bug. ***