Bug 128848 - Cannot open for edit or save files on networked drive in Kubuntu/
Summary: Cannot open for edit or save files on networked drive in Kubuntu/
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2019-11-17 00:07 UTC by Ted
Modified: 2021-09-21 09:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ted 2019-11-17 00:07:44 UTC
Description:
When a file is opened on a network drive a locked by unknown user pops up and the option given to open read only or open a copy.  When the copy is saved to the network drive an error occurs.  If a locally created document is saved to the network drive the same error occurs.

The setup is two computers running Kubuntu 19.10 on both machines. NFS network share over hardwired LAN shares drives on Computer A with Computer B. LibreOffice 6.3.2.2 was included in the distro.

LibreOffice works fine on the local drives on both machines.

Other applications including KiCAD, LibreCAD, Arduino and Kate can read/write over the network with no problems.

There are NO .~lock files anywhere on either computer. Permissions are all good. The exports and fstab entries are all RW.

FYI These two computers had been running Kubuntu 16:10 with the LibreOffice that came with it set up in a nearly identical network arrangement and it worked great. I just upgraded hard drives in both machines and did clean installs of the OS and apps.

Steps to Reproduce:
1.Open file on networked drive.
OR
2. Save file to networked drive.
3.

Actual Results:
Error message.  Option to open read only or open copy.

Error message on save.

Expected Results:
File would open for edit.
Edited file would be saved.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Only Writer and Calc have been tested.  As stated in description this set up worked with previous version of Kubuntu and LibreOffice.
Comment 1 Ted 2019-11-17 01:58:19 UTC
Version 6.2.8.2 exhibits the same problem.
Comment 2 Ted 2019-12-02 04:07:54 UTC
Problem related to NFS locking.  Problem caused by NFS file lock.  Other applications are not affected by NFS file lock.
Comment 3 Xisco Faulí 2020-05-13 11:14:54 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 QA Administrators 2020-11-11 04:18:00 UTC Comment hidden (obsolete)
Comment 5 Ted 2020-11-11 06:05:21 UTC
Per Comment #2  The problem is with a NFS File Locking setting that effects LibreOffice but not other applications.  That is the only information available.

Per Comment #3  The bug report is based on an older version.  Uncertain if the problem exists with the latest version.

The status is being changed to UNCONFIRMED.  If that leaves the bug on a "To-Do" list then mark it RESOLVED.
Comment 6 Timur 2020-11-11 13:43:07 UTC
Without reading all, rule of thumb is search before reporting. 
"Old version" message in network case is unlikely to show change. 
Please see if duplicate of bug 131388 and it's See Also bugs.
Comment 7 Dieter 2021-09-21 07:15:53 UTC
(In reply to Timur from comment #6)
> Without reading all, rule of thumb is search before reporting. 
> "Old version" message in network case is unlikely to show change. 
> Please see if duplicate of bug 131388 and it's See Also bugs.

Ted, please check, if it is a duplicate of bug 131388 and please retest with LO 7.2. Thank you.
=> NEEDINFO
Comment 8 Ted 2021-09-21 09:04:24 UTC
Close this bug report.  It is not a bug. I would kill it or close it if I could figure out how.  I changed the "Importance" to enhancement because changing the default to "nofile locking" would be an enhancement.  File locking should NOT be enabled by default.

At some point in time the defaults were changed so file locking is enabled by default on a NFS networked drive.  The issue is poor system design.  There is no direct way to enable or disable file locking.  I have learned to go to /usr/lib/libreoffice/program/soffice and edit the file to comment out the file locking settings.  I have to do this every time there is an update to LibreOffice.

My set up is two Linux computers, one in the shop and one in the office.  ALL data files are kept on the hard drive on the machine in the shop.  NFS file sharing is set up to share the shop HD with the office computer.  Every other application other than LibreOffice I can run the application in the office and open and edit the files on the hard drive in the shop.  These apps include:
LibreCAD
FreeCAD
GIMP
Okular
ARK
Kate
Arduino
Blender
Gwenview
Inkscape
and probably others.

Everything except LibreOffice.  Get the picture?  LibreOffice is out of step with the rest of the world.

The following in the file: /usr/lib/libreoffice/program/soffice
is WRONG

# file locking now enabled by default  << that is the issue
SAL_ENABLE_FILE_LOCKING=1 export
SAL_ENABLE_FILE_LOCKING


Oh, I found it.  Changed the Status to RESOLVED-WORKSFORME