Download it now!
Bug 128868 - In LibreOffice Impress Console view, clicking on the scroll bar or control buttons advances the slide
Summary: In LibreOffice Impress Console view, clicking on the scroll bar or control bu...
Status: RESOLVED DUPLICATE of bug 127921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-18 09:15 UTC by kanglinyao
Modified: 2019-12-08 09:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
console view (116.83 KB, image/png)
2019-11-25 11:00 UTC, kanglinyao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kanglinyao 2019-11-18 09:15:22 UTC
In LibreOffice Impress Console view, Presentation screen goes to next slide on any mouse click even on scroll bar, buttons and even blank area.

The bug makes navigating in console view impossible without changing the slide on the presentation screen.
Comment 1 kanglinyao 2019-11-18 23:07:54 UTC
The bug exists in MacOS,Windows and Linux using LibreOffice 6.3.3
Comment 2 Timur 2019-11-22 10:45:06 UTC
I confirm the behavior for Impress Presentation console (blank area), but I find it appropriate. You want there your presentation to proceed wherever you click (except control buttons), if mouse click is what you use.
Please explain your request in detail.

What I find wrong is behavior in Notes and Slides mode, when I use up and down keys. Presentation forwards, although I'd expect just Notes to scroll or Slides area to scroll. Back and forward keys are sufficient for presentation.

Anyway, until bug destiny is decided, I'll set from 3.3 where function is added, I think there was no change.
Comment 3 beilharz 2019-11-23 17:23:45 UTC
This Bug exists to track the wrong behaviour when clicking on the control buttons in presenter view. More explanation can be found on https://ask.libreoffice.org/en/question/217680/impress-presentation-goes-to-next-slide-on-any-mouse-click-in-presenter-console-even-on-the-scroll-bar-and-buttons/ I will change the title to make that clear.  

This Bug does not exist in 6.2.7. But in all the 6.3. Versions. I will change the earliest affected to 6.3.0.0alpha because that's the most likely from my tests. 

Versions I Checked: 
Bug does not exist: 
LibreOffice-5.4.7-x86_64.AppImage*
LibreOffice-6.1.0-x86_64.AppImage*
LibreOffice-6.2.4-x86_64.AppImage*
LibreOffice-6.2.6-x86_64.AppImage*
LibreOffice-6.2.7-x86_64.AppImage*
Bug exists:
LibreOffice-6.3.0-x86_64.AppImage*
LibreOffice-6.3.1-x86_64.AppImage*
LibreOffice-6.3.2-x86_64.AppImage*
LibreOffice-6.3.3-x86_64.AppImage*
Bug does not exist: 
LibreOffice-6.4.0.0.beta1-x86_64.AppImage*
Comment 4 beilharz 2019-11-23 17:30:10 UTC
I was not allowed to change the priority, but this should be higher. It makes the buttons in the console/ presenter view unusable. 
On the other hand, this might be a duplicate seeing that I couldn't reproduce in 6.4.0.0.beta1.
Comment 5 Timur 2019-11-23 20:25:56 UTC
Please make a screenshot and mark where you click so slide advances. 
Since per Comment 3 this may be regression, please test with daily master LO
Comment 6 Timur 2019-11-24 07:31:03 UTC
Daily master is at https://dev-builds.libreoffice.org/daily/master/. 
It will not interfere with working LO.
Comment 7 kanglinyao 2019-11-25 11:00:46 UTC
Created attachment 156088 [details]
console view

any click on anywhere will advance the presention.
Comment 8 Mike Kaganski 2019-11-25 11:57:03 UTC
Likely another dupe of tdf#127921 (as Samuel had marked tdf#127012).
Please test if it's fixed in 6.3.4.1: https://www.libreoffice.org/download/download/?version=6.3.4
Comment 9 Timur 2019-12-06 14:11:18 UTC
kanglinyao, please test LO 6.3.4 available from: https://www.libreoffice.org/download/download/?version=6.3.4
Until you reply, I set bug as Needinfo.
Comment 10 Timur 2019-12-08 09:56:17 UTC
Let's close as a duplicate, like bug 127012.

*** This bug has been marked as a duplicate of bug 127921 ***