Bug 128916 - FORMATTING: Several issues regarding indents in numbered chapter headings in a Table of Contents (TOC)
Summary: FORMATTING: Several issues regarding indents in numbered chapter headings in ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-20 12:56 UTC by noreply+666192134234234
Modified: 2019-11-27 04:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of the TOC of the test .odt document (97.13 KB, application/pdf)
2019-11-20 12:56 UTC, noreply+666192134234234
Details
Test .odt file containing the TOC configuration described above (21.27 KB, application/vnd.oasis.opendocument.text)
2019-11-20 12:58 UTC, noreply+666192134234234
Details
Individual paragraph style assigned to chapter title "Table of Figures" before the TOC is updated (102.00 KB, image/png)
2019-11-26 06:16 UTC, noreply+666192134234234
Details
Last page of TOC in a book by Achim Peters (scan) (161.54 KB, image/jpeg)
2019-11-26 07:30 UTC, noreply+666192134234234
Details

Note You need to log in before you can comment on or make changes to this bug.
Description noreply+666192134234234 2019-11-20 12:56:59 UTC
Created attachment 155973 [details]
Screenshots of the TOC of the test .odt document

I have created a test .odt document with 11 numbered chapter headings on the first chapter heading level, with a Table of Figures and a Bibliography. Some chapter headings on the first chapter heading level contain subjacent chapter headings on the second and third chapter heading level.

Within that document I created a Table of Contents (TOC). 

In order to format the display of the elements in the TOC I did the following:

For the chapter heading levels 1 to 3 I each created a tab stop at position 0,50 cm in the TOC settings on the Entries tab. I defined values for indents in the fields "Before text" and "First line" at the "Indents & Spacing" tab in the paragraph style settings of "Contents 1", "Contents 2" and "Contens 3"

The displayed TOC contains several formatting errors, i.e.:

Issue 1:

The space between chapter number 1.2.1 and the beginning of its chapter heading text is bigger than the space between the chapter numbers 1 to 9 and their respective chapter heading texts. The second and all other subsequent lines of the chapter heading starting with the number 1.2.1 do not begin at the same vertical position as the first letter of the first word of the chapter heading 1.2.1

Issue 2:

In comparison to the headings of chapters 1 to 9, chapter 10 and 11 contain more space between their chapter numbers and their first words in their first lines of their chapter headings. The second and all other subsequent lines of the headings of chapters 10 and 11 do not begin at the same vertical position as the first letter of the first words of chapter headings 10 and 11.

Issue 3:

The chapter heading starting with number 10.1 is affected by the same issue as issue 1.

Issue 4:

The chapter heading starting with number 10.2.1 is affected by the same issue as issue 1.

Issue 5:

The chapter headings "Table of Figures" and "Bibliography" do not contain chapter numbers, and this with full intent. These kind of chapters should not each have a chapter number. In the TOC, these chapter names are not displayed at the left edge of the text area, but are indented to the right. But they should be displayed at the left edge of the text area.

For a demonstration of these issues, refer to the attached PDF file containing screenshots of the TOC of the test .odt document described above. I also attached the test .odt file containing the TOC configuration described above.
Comment 1 noreply+666192134234234 2019-11-20 12:58:34 UTC
Created attachment 155974 [details]
Test .odt file containing the TOC configuration described above
Comment 2 Timur 2019-11-22 21:04:51 UTC
Please search for existing ToC bugs.
Comment 3 Timur 2019-11-24 11:58:54 UTC
Rule of thumb is to search existing bugs before reporting. I add bug 32360 to See Also, and draw attention to bug 118962.

Another rule is to reports issues separately. But I still looked what's written.

Issue 1, 3, 4. You changed "Contents" styles and that doesn't make bug. Same content is shown differently in default ToC in another document. NotaBug.

Issue 2 is a result of space and not tab after entry, not enough room.
I'd say this is bug 32360 so duplicate.

Issue 5 is different and should've been reported separately. These indexes behave exactly as headings and begin from the same position. Seen if headings don't have numbers. 
My view is WontFix on that.  

I'll mark the whole report as Invalid. 
Feel free to comment whether something is new here that would deserve a separate bug.
Bear in mind that we require both "experienced and expected" results.
In Issue 5 by trying to write expected results, you'd see it would be hard to change something, because anyone can and doesn't have to use numbering in ToC. What you did and explained is just one case.
Comment 4 Dieter 2019-11-24 12:04:42 UTC
Jens, you just have to modify the paragraph styles

contents 2 for level 2
contents 3 for level 3
contents 1 for level 1

=> RESOLVED NOTABUG
Comment 5 noreply+666192134234234 2019-11-24 13:27:02 UTC
I do not understand why issue 5 is not a bug issue. My productive odt. document, which shows all the issues described above, has chapter headings with numbers and a Table of Figures and a Bibliography - the names of these indexes should not have numbers in the TOC (because they are no normal chapters) and should be displayed there at the left edge of the text area - for me this is a bug.

And it is not possible to resolve parts of the descriptions of issue 1 to 4 by changing the paragraph styles "Content 1", "Content 2" and "Content 3".
Comment 6 Timur 2019-11-24 16:03:12 UTC
I also do not understand Dieter's message. 
Maybe he wrote at the same time as me. NAB could do for Issue 1. I marked Invalid for the whole bug.

As for Issue 5., I explained it is different and doesn't belong to this report. 
These indexes behave exactly as headings and begin from the same position. Seen if headings don't have numbers:
1. heading
   heading
   index

As I also pointed out, you are looking from a single document and wish to align.
But design is number-space-title (space is wrong but that's reported bug). You cannot make differently just because you want index align left with numbers. 
"Bear in mind that we require both "experienced and expected" results."
Not clear how all that could be rearranged, what' expected in any combination. 
It's not "this doesn't look as I'd want" but "that should be done better like this".
And besides that's it's hardly feasible, it's just such a trivial issue that's not worth discussing. 

Issue 2 (that's most important here) is more likely a duplicate of this one:
https://bugs.documentfoundation.org/show_bug.cgi?id=56258
Comment 7 Dieter 2019-11-25 17:52:16 UTC
Jens, problem with issue 5 is, that you use the same paragraph style as for headings in level 1. Since you set a tab for them before the entry you get the same result for Table of Figures and Bibliography. You shout choose a different paragraph style for them.

In sum: NOTABUG
Comment 8 noreply+666192134234234 2019-11-26 06:13:33 UTC
(In reply to Dieter Praas from comment #7)
> Jens, problem with issue 5 is, that you use the same 
> paragraph style as for headings in level 1. Since you 
> set a tab for them before the entry you get the same 
> result for Table of Figures and Bibliography. You 
> shout choose a different paragraph style for them.

I tried to implement your solution proposal, assuming that I understood you correctly, but it does not work:

1. I disabled the option "Protect against manual changes" in the TOC settings - something which I do not like to do. But I did that in order to be able to implement the following steps:

2. I defined an individual paragraph style "Contents 1 Alternative" based on the paragraph style "Contents 1". In this individual style I set the values for the Indents & Spacing to 0 in the fields "Before text" and "First line", and I set the Outline Level to Level 1.

3. In the TOC I assigned the chapter title "Table of Figures" to the individual style "Contents 1 Alternative".

This causes the chapter title "Table of Figures" being displayed at the right edge of the text area in the TOC (not desired), and a second line is displayed below that which only shows single dots and the page number at the right edge of the text area (not desired). Refer to the attached screenshot.

4. If I then update the TOC, the chapter titles "Table of Figures" and "Bibliography" are again not directly displayed at the left edge of the text area of the TOC, but at the same vertical position as the chapter titles of chapter 1 to 9, i. e. in the same way as previously described here in this bug report in issue 5.

So this does not work.

By the way, if one defines a tab stop on the Entries tab in the TOC settings, how can I delete this tab stop again? It's not possible.
Comment 9 noreply+666192134234234 2019-11-26 06:16:21 UTC
Created attachment 156119 [details]
Individual paragraph style assigned to chapter title "Table of Figures" before the TOC is updated
Comment 10 noreply+666192134234234 2019-11-26 07:29:30 UTC
@Timur / (Dieter): As I understand you, you are of the opinion that issue 5 is something that only affects me because only I would like to have the chapter titles "Table of Figures" and "Bibliography" being displayed at the left edge of the text area in the TOC, on the same vertical position like the numbers of normal chapters.

Let me demonstrate to you that my desire to have such an vertical arrangement of chapter titels and indexes is not an individual desire. The following two links contain PDF files with TOCs exactly showing this kind of vertical arrangement:

Document A:

https://www.bmel.de/SharedDocs/Downloads/Ministerium/Historiker_Zwischenbericht.pdf?__blob=publicationFile

=> This document is a document published on the web site of the German Ministry of Agriculture and Nutrition

=> At the end of the TOC the chapter titels "Schlussbemerkung" ("Final Remark") and "Mitglieder und Mitarbeiterinnen und Mitarbeiter der Unabhängigen Historikerkommission beim Bundesministerium für Ernährung und Landwirtschaft" ("Members and Staff of the Independent Historian Commission at the Ministry of Agriculture and Nutrition") have no chapter numbers and begin at the left edge of the text area in the TOC, like the chapter titles above them, with chapter titles starting with Roman/Latin numbers.

Document B:

https://www.ifz-muenchen.de/fileadmin/user_upload/Neuigkeiten%202016/2016_02_13_ZZF_IfZ_PM_BKM-Studie_FINAL_Neu.pdf

=> This is a scientific text in German, too.

=> At the end of the TOC the chapter title "Anhang" ("Appendix") has no chapter number and begins at the left edge of the text area in the TOC, like the chapter titles on level 1 above them, with chapter titles starting with numbers.

Document C:

Document C is scanned from a book with the title "Unsicherheit. Das Gefühl unserer Zeit" by the German brain scientist Achim Peters, published in 2018. This scan shows the last page of its TOC. In the TOC, the chapter titles "Dank" ("Thanks to" or "Gratitude"), "Anmerkungen" ("Remarks") and "Register" ("Register") have no chapter numbers and begin at the left edge of the text area in the TOC, like the chapter titles above them, with chapter titles starting with numbers.

Summary:

At least in Germany and possibly in Austria and in the German speaking parts of Switzerland and Belgium this kind of vertical arrangement of chapter titles with numbers and no numbers in their chapter titles at the same vertical position in TOCs is a standard arrangement.
Comment 11 noreply+666192134234234 2019-11-26 07:30:59 UTC
Created attachment 156120 [details]
Last page of TOC in a book by Achim Peters (scan)
Comment 12 Timur 2019-11-26 10:40:43 UTC
Jens, please do not misuse Bugzilla as support forum for your specific modified documents.

In NEW document, chapter titles "Table of Figures" and "Bibliography" ARE displayed at the left edge of the text area in the TOC, on the same vertical position like the numbers of normal chapters.

You should first ask at https://ask.libreoffice.org.
Comment 13 noreply+666192134234234 2019-11-26 12:48:30 UTC
(In reply to Timur from comment #12)
> You should first ask at https://ask.libreoffice.org.

I did that already on 18th November 2019 (in German): No one could help me.
Comment 14 noreply+666192134234234 2019-11-27 04:08:09 UTC
(In reply to Timur from comment #12)
> In NEW document, chapter titles "Table of Figures" and "Bibliography" ARE
> displayed at the left edge of the text area in the TOC, on the same vertical
> position like the numbers of normal chapters.

Which kind of an odt document did I upload into this bug report? A new document or my productive document? What does the uploaded screenshot of the odt document show? My productive odt document or a new document?

Anyway, yesterday I requested the deletion of my Bugzilla account.