Download it now!
Bug 129029 - FORMATTING: Incorrect page count using paragraph style with page break before and page number
Summary: FORMATTING: Incorrect page count using paragraph style with page break before...
Status: RESOLVED DUPLICATE of bug 126284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Statusbar Writer-Page-Break
  Show dependency treegraph
 
Reported: 2019-11-26 04:09 UTC by Mike
Modified: 2020-02-06 18:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case demonstrating result (8.38 KB, application/vnd.oasis.opendocument.text)
2019-11-26 04:14 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2019-11-26 04:09:26 UTC
Description:
Using a paragraph style with the insert page break before setting enabled, and the with page style and page number settings enabled results in an incorrect total page count.

This result is visible in the page count in the UI, as well as when using the page count field in the document.

Steps to Reproduce:
1. Open a new blank document in Writer and enter two paragraphs of text.

2. Select the second paragraph, and open the Paragraph properties.

3. In the Text Flow tab under Breaks, enable the check boxes for "Insert", "With Page Style", and "Page number". Type is Page, Position is Before, Page Style is Default Style, and Page number is 1. (Page number check box is not present in LO 3.3.0)

Actual Results:
The page total count in the bottom left of the UI is now 3. Inserting Fields > Page Count also displays the count as 3.

Expected Results:
The page count should be 2.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
I have reproduced this in versions 3.3.0, 6.3.3.2, 6.5.0.0.alpha0.

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-AU (en_AU); UI-Language: en-GB
Calc: threaded

Version: 6.5.0.0.alpha0+ (x64)
Build ID: d312d02cf43928361be34207a0cdd2d95b3ec5fd
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-AU (en_AU); UI-Language: en-GB
Calc: CL
Comment 1 Mike 2019-11-26 04:14:37 UTC
Created attachment 156114 [details]
Test case demonstrating result

The attached test case has all steps to reproduce the issue applied to it.

This specific case was created and demonstrated issue in LO 6.3.3.2.
Comment 2 Dieter 2019-11-26 07:43:26 UTC
Mike, this is the intended behaviour, but perhaps documentation culd be improved.

see bug 126284

cc: Oliver Hallot
cc: Design-Team for decision, if we leave bug open, close it or change to docmentation
Comment 3 Heiko Tietze 2019-11-26 13:03:53 UTC
(In reply to Dieter Praas from comment #2)
> cc: Design-Team for decision, if we leave bug open, close it or change to
> docmentation

Would make it a duplicate. But let's first see if Mike agrees => NEEDINFO
Comment 4 Mike 2019-12-04 07:20:48 UTC
Apologies for the delay. Yes, that will be fine.

Thank you for the explanation.
Comment 5 Heiko Tietze 2019-12-04 07:23:12 UTC

*** This bug has been marked as a duplicate of bug 126284 ***