Download it now!
Bug 129039 - Add the ability to insert the phrase "Continuation of the table ..." before the part of the table that has been moved to a new page
Summary: Add the ability to insert the phrase "Continuation of the table ..." before t...
Status: RESOLVED DUPLICATE of bug 114467
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Enhancements
  Show dependency treegraph
 
Reported: 2019-11-26 12:31 UTC by Maxim
Modified: 2020-03-02 15:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim 2019-11-26 12:31:31 UTC
Description:
When moving a table to the next page, you often need to duplicate its title in the form "Continuation of the table (title or table number)." Now you have to do this manually, which takes a lot of time if the table is long. When editing a table, you often have to repeat all the work, because the pagination of the table changes.
It would be great if you added the function of adding a title to parts of tables that were automatically transferred to the following pages.


Actual Results:
When automatically moving part of a table to the next page, it is not possible to add the title of the transferred part of the table, for example, "Continuation of the table (table name or number)."


Expected Results:
The ability to determine the header format for the part of the table automatically transferred to the next page, for example, "Continuation of the table (table name or number)."
The header is displayed before the part of the table automatically transferred to the next page.



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Heiko Tietze 2019-11-27 09:54:21 UTC
Would be a nice enhancement, indeed. Your workflow probably means: 
* split the table at the right position 
* copy the caption from above and insert as text (watch closely to update on changes) or use cross-reference to this field
* add some text like "contd." to the caption

While it might be possible it likely needs a lot of development effort. 

UI-wise we could add an option "[ ] Repeat table caption" enabling the edit "add: [       ]". 
I wouldn't add things like "add before [  ] mid [   ] after [   ]" with special references to achieve, for example "Continuation of the table 5." Rather have "Table 5: Foo (continued)"
Comment 2 Maxim 2019-11-27 11:43:16 UTC
The problem is that the table header is now processed and configured separately from the table. And it is not clear what is generally the heading of the table in the document.
It would be better if the table title was configured in its properties. And the table title would be a bit of an auto-assembled table of contents without the possibility of direct editing.
In this case, you can specify two formats for the headers, one for the first part of the table, the second for the rest of the table.

for example

Table N - Statement of documents.
Continuation of table N.

Just two text fields with the ability to add any text and a special code for the automatic table number.
Comment 3 Heiko Tietze 2019-11-27 14:09:32 UTC
(In reply to Maxim from comment #2)
> Table N - Statement of documents.
> Continuation of table N.

But the "table title" is a caption with all limitations. You also want this for figures, formulas, etc.
Comment 4 Thomas Lendo 2020-02-29 23:05:32 UTC
Seems to be a duplicate of Bug 114467 - EDITING: Allow repeating of table caption if table crosses page
Comment 5 Heiko Tietze 2020-03-02 15:11:57 UTC

*** This bug has been marked as a duplicate of bug 114467 ***