Download it now!
Bug 129082 - Dialog "Insert sheet from file" in Calc hangs at "Insert Sheet" dialog for LO version >6.2
Summary: Dialog "Insert sheet from file" in Calc hangs at "Insert Sheet" dialog for LO...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0.1 target:6.5.0 target:6.3.5
Keywords: bibisectNotNeeded, regression
: 129091 130245 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-28 13:36 UTC by ron meisels
Modified: 2020-01-29 12:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ron meisels 2019-11-28 13:36:45 UTC
Description:
When I try to use menu item "Sheet"->"Insert Sheet from Table"
I can select the file name but then it hangs at the "Insert sheet" dialog and
never reaches "Text Import"

Steps to Reproduce:
1.Select menu "Sheet"
2.Select item "Insert Sheet from File"
3.Select file

Actual Results:
"Insert sheet" dialog appears but 
"Text Import" dialog never appears


Expected Results:
Creating a new sheet from the data in the file


Reproducible: Always


User Profile Reset: No



Additional Info:
"Insert Sheet From File" works fine in
Version: 6.2.8.2 (x64)

but not in 6.3 and version: 6.4.0.0.beta1 (x64)
so I "back"graded to 6.2

OS is Windows 7
In Linux Mint version 6.2 I use and therefore it works.
Comment 1 Xisco Faulí 2019-11-28 15:57:01 UTC
Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: 2bf687bebb30defe576ddb20c1c9680979ed3086
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

When I import a CSV file the Text import dialog is not displayed but it doesn't hang.
Anyway, the fix is already in gerrit: https://gerrit.libreoffice.org/#/c/84014/
Comment 2 Commit Notification 2019-11-28 16:32:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c8ef1fcb49abb1222f9e4d329adb8a6a744be0f6

Related: tdf#129082 set explicit parent for warning dialog

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2019-11-28 19:14:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5030be4e85179147476b1e441eb618fb6ed58235

Related: tdf#129082 set explicit parent for warning dialog

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-11-28 21:21:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0c4736a3e6b6e641579f517cf134ce2fd89fe132

Resolves: tdf#129082 insert sheet from file fails

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2019-11-29 08:58:58 UTC
Fixed in master, and included with the fixes of https://gerrit.libreoffice.org/plugins/gitiles/core/+diff/f3d4c125775b00432a2ef8db329c23c793abc40f%5E%21 for 6-4, backport to 6-3 in gerrit
Comment 6 Commit Notification 2019-11-29 10:00:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/a12038fd8f6c7f276b616093c613c4fc19f75a59

Related: tdf#129082 set explicit parent for warning dialog

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-11-29 10:11:26 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 63acb8cfa4d66baf48a0fe5cdc9ababb6f981666
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 8 Julien Nabet 2019-11-29 20:05:54 UTC
*** Bug 129091 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2020-01-29 12:52:59 UTC
*** Bug 130245 has been marked as a duplicate of this bug. ***