Bug 129138 - libUEMF test EMF not displaying correctly
Summary: libUEMF test EMF not displaying correctly
Status: RESOLVED DUPLICATE of bug 55058
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf
Depends on: 129147 129106 129188 129308
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2019-12-01 21:45 UTC by Chris Sherlock
Modified: 2019-12-12 10:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PNG of what test emf file should look like (646.56 KB, image/png)
2019-12-01 21:46 UTC, Chris Sherlock
Details
libUEMF v0.2.1 test image (196.89 KB, image/x-emf)
2019-12-01 21:50 UTC, Chris Sherlock
Details
test image on 6.5.0 alpha (master) (192.27 KB, image/png)
2019-12-02 00:34 UTC, Chris Sherlock
Details
Test image in Office 365 (578.43 KB, image/png)
2019-12-02 00:40 UTC, Chris Sherlock
Details
test image on 6.5.0 alpha (master) - same size as Office 365 (1.35 MB, image/png)
2019-12-02 00:48 UTC, Chris Sherlock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Sherlock 2019-12-01 21:45:17 UTC
Description:
libUEMF April 23, 2015 test image is not displaying fully in LibreOffice. Consider this the ultimate test EMF image, if we get this displaying correctly then we will have resolved most of our EMF compatibility issues. 

Steps to Reproduce:
Open the attached test EMF image from the libUEMF project: test_libuemf_p_ref.emf



Actual Results:
There are a variety of missing or incorrectly displayed elements.

Expected Results:
It should look like the PNG image I generated from Office 365 on my Mac. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Chris Sherlock 2019-12-01 21:46:12 UTC
Created attachment 156229 [details]
PNG of what test emf file should look like
Comment 2 Chris Sherlock 2019-12-01 21:50:09 UTC
Created attachment 156230 [details]
libUEMF v0.2.1 test image
Comment 3 Chris Sherlock 2019-12-01 21:52:23 UTC
Bartosz, I've found our ultimate test image to see how well we are tracking with the EMF imports.
Comment 4 Chris Sherlock 2019-12-02 00:34:27 UTC
Created attachment 156231 [details]
test image on 6.5.0 alpha (master)
Comment 5 Chris Sherlock 2019-12-02 00:40:48 UTC
Created attachment 156232 [details]
Test image in Office 365
Comment 6 Chris Sherlock 2019-12-02 00:48:07 UTC
Created attachment 156233 [details]
test image on 6.5.0 alpha (master) - same size as Office 365
Comment 7 Chris Sherlock 2019-12-12 10:17:57 UTC
If you have a debug build of LibreOffice, then set the following environment variable:

export SAL_LOG="+INFO.drawinglayer+WARN"
Comment 8 Chris Sherlock 2019-12-12 10:32:26 UTC

*** This bug has been marked as a duplicate of bug 55058 ***