Download it now!
Bug 129155 - CALC: UI: showing wrong formula in formula bar
Summary: CALC: UI: showing wrong formula in formula bar
Status: RESOLVED DUPLICATE of bug 129141
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-03 06:01 UTC by b.
Modified: 2019-12-03 11:10 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
6_2_8_2_showing_wrong_formula (19.30 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-12-03 06:04 UTC, b.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description b. 2019-12-03 06:01:04 UTC
Description:
hello @all, 

funny, i think i reported a bug yesterday, can't find it today, second try, sorry if double ... 

take file from next comment, click in B1, enlarge formula-bar (triangle on right end), step with the cursor keys! to B2, B3, B4, and watch the formula *not changing*. proceed to B5, formula disappears, and go up again, another - quite similar - formula appears, and again remains unchanged while you cursor-step to B3, B2. either may be right, the formula shown or the results, not both. 

the correct - and different - formulae are correctly stored for the cells, you can check with F2, but are presented wrong to the user. 

such behavior irritates unsuspecting users and is likely to raise doubts about the integrity of the program. 

entering the cells by mouseclick worked correctly - on my tries - as well as different versions of calc produced slightly different misbehaviour, but all from 4.1.6.2 to 6.5.0.0alpha0+ failed, even in the safe settings without CL and 'unthreaded'. 

have fun to dig down ... 

observed side effect: inserting blank cells / rows between the red cells blocks the effect, hiding those rows let's it step in again ... 

Steps to Reproduce:
see above description and file in next comment, i tested with a 64bit win machine, can't yet tell about lin or 32-bit versions. 

Actual Results:
wrong formula shown in the formula bar

Expected Results:
the same formula in the bar as you see in the cell when editing (F2)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.8.2 (x64)
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 8; OS: Windows 6.1; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: 

version with which the file was created, other versions fail too
Comment 1 b. 2019-12-03 06:04:23 UTC
Created attachment 156258 [details]
6_2_8_2_showing_wrong_formula

see bug report, stepping through the three red marked cells with the cursor keys shows formulae in the formula bar which don't fully match the formula in the cells.
Comment 2 Timur 2019-12-03 11:10:24 UTC

*** This bug has been marked as a duplicate of bug 129141 ***