Download it now!
Bug 129156 - Regression: cant open xls file anymore with new libreoffice version with error: malformed_xml_error
Summary: Regression: cant open xls file anymore with new libreoffice version with erro...
Status: RESOLVED DUPLICATE of bug 126515
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-03 09:39 UTC by Andrius Jurkus
Modified: 2019-12-03 10:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File to reproduce bug (34.58 KB, text/xml)
2019-12-03 09:40 UTC, Andrius Jurkus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrius Jurkus 2019-12-03 09:39:19 UTC
Description:
Long story short... Our government provides weird xls files and...

Version: 6.2.8.2
Build ID: 1:6.2.8~rc2-0ubuntu0.18.04.1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: lt-LT (lt_LT.UTF-8); UI-Language: en-US
Calc: threaded

libreoffice ./Desktop/dokumentas2.xml  (yeah I renamed file it should be .xls)
1:14: <?xml version = '1.0' encoding = 'utf-8'?>
                   ^
malformed_xml_error: Attribute must begin with 'name=..'. (ns='', name='version')

but with 
Version: 5.3.4.2 (x64)
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
CPU Threads: 8; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: lt-LT (lt_LT); Calc: group

same file opens just fine. I also tried 6.1 on linux

From my friend I heard that this regression happens regularly.



Steps to Reproduce:
1. Open file

Actual Results:
With new version nothing with old version it opens.

Expected Results:
Always opens


Reproducible: Always


User Profile Reset: No



Additional Info:
I edited out actual information directly from xml, and results are unchanged you still can open file with old libre.
Comment 1 Andrius Jurkus 2019-12-03 09:40:15 UTC
Created attachment 156263 [details]
File to reproduce bug
Comment 2 Xisco Faulí 2019-12-03 10:12:34 UTC
Thanks for reporting this issue.
this is a duplicate of bug 126515. It's fixed in LibreOffice 6.4

*** This bug has been marked as a duplicate of bug 126515 ***