Bug 129209 - Document XInfobarProvider
Summary: Document XInfobarProvider
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.4.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2019-12-05 15:43 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2021-10-20 10:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2019-12-05 15:43:03 UTC
Infobar has a UNO API since 6.4. See Release Notes: https://wiki.documentfoundation.org/ReleaseNotes/6.4#Infobar

The commit has examples in BASIC: https://gerrit.libreoffice.org/plugins/gitiles/core/+/9e3ba7c3036c4d21e01d6f75ed29a1e8c4208141%5E%21
Comment 1 Xisco Faulí 2019-12-11 14:03:01 UTC
Moving to NEW
Comment 2 Commit Notification 2021-10-20 06:22:58 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5c16ac64ef02481ccf19b65f5702caf4b67b888d

tdf#129209 Doc't XInfobarProvider.idl

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.