Download it now!
Bug 129230 - Alignment problem? - Significant Offsets and vertically streched when Cropping Image in LibreOffice Draw
Summary: Alignment problem? - Significant Offsets and vertically streched when Croppin...
Status: RESOLVED DUPLICATE of bug 40259
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-06 11:13 UTC by VINCE WANG
Modified: 2020-05-01 17:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description VINCE WANG 2019-12-06 11:13:29 UTC
Description:
When using a shape, e.g. a Sqare, as a mask to Crop (Intersect) an image in the back, the result shows Significant Offsets.
Seems like an alignment problem.
Tried differrent shapes and all yield the same problem.
Also the processed result is vertically streched (out of proprotion) .
Hopefully this issue could be fixed in the near future.
Thanks a lot for making such a powerful tool for the world! 

Steps to Reproduce:
1. Insert or Paste a bitmap into a new page;
2. Insert a shape e.g. a square over the previous image;
3. Intersect to crop the bitmap into desired shape
 

Actual Results:
 End result shows significant discrepancy from the original bitmap(Proportion, Horizontal Range and Vertical Range).

Expected Results:
Exact Proportion, Horizontal Range and Vertical Range.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Although the vertical distortion (strecthed) and roughly fixed by vertically transformation to get acceptable result, this bug is relatively annoying.
Comment 1 Xisco Faulí 2019-12-11 13:58:41 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest vers
Comment 2 VINCE WANG 2019-12-11 17:12:26 UTC
Problem persists on Version 6.3.3.2.


[Bug 129230] Alignment problem? - Significant Offsets and vertically streched when Cropping Image in LibreOffice Draw

Thank you.
Comment 3 QA Administrators 2019-12-12 03:41:48 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2020-05-01 17:35:59 UTC

*** This bug has been marked as a duplicate of bug 40259 ***