Download it now!
Bug 129267 - Measurement unit in sidebar is not changing on Margins
Summary: Measurement unit in sidebar is not changing on Margins
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All All
: low minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:7.0.0
Keywords:
: 103385 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-07 17:20 UTC by BogdanB
Modified: 2020-08-10 17:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
video showing the bug (770.68 KB, video/mp4)
2019-12-07 17:21 UTC, BogdanB
Details
video (608.06 KB, video/mp4)
2019-12-09 13:40 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BogdanB 2019-12-07 17:20:39 UTC
Description:
Measurement unit in sidebar is not changing in Margins after changing the Measurement unit in Tools - Options - LibreOffice Writer - General - Settings.

Width and height are changing from cm to inch, and from inch to cm. But the margins remain as cm.

Steps to Reproduce:
1. Changing Measurement unit in Tools - Options - LibreOffice Writer - General - Settings from cm to inch
2. Open the sidebar: width and height are changing their units, but margins NOT.

Actual Results:
just width and height (NOT MARGINS) change their measurement unit

Expected Results:
width and height AND MARGINS should change their measurement unit


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.0.0.beta1
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 BogdanB 2019-12-07 17:21:08 UTC
Created attachment 156397 [details]
video showing the bug

video showing the bug
Comment 2 BogdanB 2019-12-09 13:40:56 UTC
Created attachment 156434 [details]
video

Another video. First not working
Comment 3 Xisco Faulí 2019-12-09 14:36:14 UTC
Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: 46a07f2042a812fc552e26736183c7d06fe6aa35
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Opening LibreOffice again fixes the issue...
Comment 4 BogdanB 2019-12-09 14:54:10 UTC
It's the same in 
Version: 6.2.7.1
Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

It's something very old.
Comment 5 BogdanB 2019-12-09 14:56:29 UTC
I supose it is hardcoded that text.
Comment 6 Xisco Faulí 2019-12-09 15:02:42 UTC
This issue started to happen after https://cgit.freedesktop.org/libreoffice/core/commit/?id=6d9a2557a0f0366fff169f3c3581414b3cec80bd, before that, margin was always in inches.
@Caolán, I thought you might be interested in this issue...
Comment 7 BogdanB 2019-12-09 15:11:18 UTC
Also there should be a space between number of cm and "cm". For example "1.9cm" should be "1.9 cm", and maybe even better with comma: "1,9 cm", like it is above in width and height of the page.
Comment 8 Commit Notification 2019-12-09 19:47:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6552ce0f510da67be02a5102016bd14957a25a85

Related: tdf#129267 separate cm from value in built-in en_US strings

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-12-09 19:48:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c1e2acd58e38d4d51285eb522f2dfbde10267f75

Resolves: tdf#129267 change margin unit when measurement unit changes

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-12-09 21:26:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fc280552a5ee0131a08aeea5ccfd8cb7b9a6225d

Related: tdf#129267 change spacing unit when measurement unit changes

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Gabor Kelemen 2019-12-10 10:17:04 UTC
Bug #103385 is about this problem too.
Comment 12 Caolán McNamara 2019-12-10 10:19:31 UTC
*** Bug 103385 has been marked as a duplicate of this bug. ***
Comment 13 Caolán McNamara 2019-12-10 10:20:20 UTC
(In reply to Gabor Kelemen from comment #11)
> Bug #103385 is about this problem too.

looking at that I think this will solve those issues too
Comment 14 Commit Notification 2019-12-10 20:29:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/137c9e826cdce429a004f05bde40d274437d7554

Related: tdf#129267 format numbers with the UI locale

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2019-12-11 09:14:59 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: b9d6ea1dd7541c4bd866571f9e3f0aa894687c07
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 16 Commit Notification 2019-12-11 09:19:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f60f4d906d2ee6ae15a2178d36e6c766d1a28d56

Resolves: tdf#129267 change margin unit when measurement unit changes

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-12-11 09:22:13 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/6d87a3ab7947ab862c56f1c73c8ca1b08411adcf

Related: tdf#129267 change spacing unit when measurement unit changes

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-12-11 10:28:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d90044c533683146c62e7b0848999eb76c7ef3ec

Related: tdf#129267 draw also has a similar panel combobox

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2019-12-11 10:28:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b26f29a976838247175576f17fb4a3087e1bb922

Related: tdf#129267 format numbers with the UI locale

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2019-12-11 11:31:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/6ea6f61d4fabc81ac482ead028259a64608f0c48

Related: tdf#129267 draw also has a similar panel combobox

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2019-12-11 13:18:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/46604b1a38d800fd70a22be0ee18668b131038a6

Related: tdf#129267 format numbers with the UI locale

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Caolán McNamara 2019-12-11 13:20:18 UTC
fixed in master and 6-4
Comment 23 Commit Notification 2020-05-24 21:44:27 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/94f9b77b73d8c8bc6579bcd54861c76dc1e94f22

tdf#133189, tdf#129267: sw: Add UItest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.