Bug 129401 - gtk2: OK button disabled in bullets and numbering dialogue when selecting "None"
Summary: gtk2: OK button disabled in bullets and numbering dialogue when selecting "None"
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GTK2
  Show dependency treegraph
 
Reported: 2019-12-14 09:04 UTC by Heinrich Schuchardt
Modified: 2021-12-29 13:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heinrich Schuchardt 2019-12-14 09:04:08 UTC
The following was observed on Debian Buster LibreOffice 6.3.3.2.0 30(Build:2)

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=946708.

In libreoffice impress the "Bullets and Numbering" dialogue allows to select
a bullet format. On of the available formats is "None".

If "None" is selected the OK button reacts neither to a mouse click nor to
ALT+O. The only possibility to press OK is to use the tab key multiple times to reach OK and press the spacebar.

The OK button should not be disabled by selecting "None" as bullet format.

Best regards

Heinrich
Comment 1 raal 2019-12-14 15:27:24 UTC
I cannot confirm with Version: 6.4.0.0.beta1+
Build ID: 4cd89b652d9de01d4d0e24332d351e8df4089cf0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 2 Rene Engelhard 2019-12-15 09:23:30 UTC
I can confirm this in 6.3.3 as in Debian testing.

But only with gtk2.

gtk3, qt5 (and thus probably kde5) work.
Comment 3 Heinrich Schuchardt 2019-12-15 11:17:31 UTC
sudo apt-get remove libreoffice-qt5

fixed the problem for me on Debian Bullseye with KDE.

So something must be broken with this KDE integration package which is based on libreoffice_6.3.4.

Best regards

Heinrich
Comment 4 QA Administrators 2021-12-15 04:41:20 UTC Comment hidden (obsolete)
Comment 5 Ezinne 2021-12-29 13:41:25 UTC
Closing this issue because the gtk2 VCL backend has been removed from LibreOffice.