Bug 129409 - Columns shrink on every save in XLSX file
Summary: Columns shrink on every save in XLSX file
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-14 19:27 UTC by The Lazy Crazy Brain
Modified: 2019-12-15 17:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Testfile created with Exel and edited with LO demonstrating the bug (5.31 KB, application/zip)
2019-12-15 08:35 UTC, The Lazy Crazy Brain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description The Lazy Crazy Brain 2019-12-14 19:27:33 UTC
If I open an XLSX file, make a change (any change will do, eg. change the content of a cell), save it and reopen the document (closing Calc or just close the document and reopen it), all column sizes in all tables across the document will shrink.


This happens throughout all versions since v. 6.2.8
Comment 1 Oliver Brinzing 2019-12-15 07:57:25 UTC
Thank you for reporting the bug. 

Please attach a sample document, as this makes it easier for us to verify the bug. 

(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 The Lazy Crazy Brain 2019-12-15 08:35:32 UTC
Created attachment 156591 [details]
Testfile created with Exel and edited with LO demonstrating the bug

Changes made to this document make the columns shrink.
Comment 3 Timur 2019-12-15 09:43:01 UTC
Xlsx you attached is wrong, because it's already modified by LO. 
We need source Xlsx from Excel (as in other cases source Ods from LO).
Comment 4 Timur 2019-12-15 09:57:53 UTC
Let me add that we had similar big fixed for LO 5.3. If you have just LO-modified Xlsx before that. All details may be relevant. Bug is only if we reproduce from Excel ource Xlsx.
Comment 5 The Lazy Crazy Brain 2019-12-15 10:57:02 UTC
This is the only file I can provide because I don't use Microsoft Office anymore and neither do I have it installed or a license for it.
I first opened the file in LO 6.3.3. 

But still - it is a bug. Whether LO corrupted the file with a previous bug or it is a current bug during the import. The file is corrupted in any way and there is no way for me now to fix that.
I already had to remove almost all conditional formatting because LO showed empty cells at some random point in time, but there is no obvious workaround for this bug is there?
Comment 6 Timur 2019-12-15 17:42:00 UTC
Even though source is not proper, I tested with LO 6.2.8, 6.3.3 and 6.5+ in Windows and couldn't reproduce.
So I'll close.
When reporting a bug, there's a question if you tried with User Profile Reset.
Seems you skipped that. And that's what you should try.