Download it now!
Bug 129410 - CRASH: Corrupted spreadsheet, unable to open in Linux
Summary: CRASH: Corrupted spreadsheet, unable to open in Linux
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-15 04:40 UTC by Luis
Modified: 2020-11-25 13:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple spreadsheet that got corrupted and can't be opened by libreoffice but possible with at least google docs (12.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-12-15 04:42 UTC, Luis
Details
crash backtrace (44.85 KB, text/x-log)
2020-03-31 16:16 UTC, Eike Rathke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luis 2019-12-15 04:40:13 UTC
Description:
Very simple spreadsheet created with LibreOffice (.ods) got corrupted by LibreOffice (I guess).

Libreoffice can't open the corrupted file and goes into an endless "bootloop" showing the start splash screen repeatedly.

Opening the corrupted file with google docs shows all the information as it was saved last time

Steps to Reproduce:
1.Try to open the attached file
2.
3.

Actual Results:
LibreOffice crashes and shows the Document recovery dialog with no items to recover
OR
LibreOffice starts an endless "bootloop" and soffice.bin has to be killed with command prompt

Expected Results:
LibreOffice Shows the document contents


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.3.2.0+
Build ID: 1:6.3.3-3
CPU threads: 12; OS: Linux 5.3; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Luis 2019-12-15 04:42:26 UTC
Created attachment 156590 [details]
Simple spreadsheet that got corrupted and can't be opened by libreoffice but possible with at least google docs
Comment 2 Xavier Van Wijmeersch 2019-12-15 07:58:28 UTC
When the document is opening it crash LO

crashreport.libreoffice.org/stats/crash_details/57ea9aa3-92d1-4a71-8993-f44fbb0403ac => LO 6.3.2.2

crashreport.libreoffice.org/stats/crash_details/1602c602-3916-468f-8b9f-65f753c49cec => LO 6.3.4.2

But its open with gnumeric and AOO 4.5.0alpha
Comment 3 Oliver Brinzing 2019-12-15 08:12:57 UTC
I can't reproduce a crash with:

Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

Linux only issue?
Comment 4 m.a.riosv 2019-12-16 21:47:00 UTC
I can open, save and open again.
Version: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc:
Comment 5 duceil 2019-12-22 12:17:15 UTC
Myself had an ods calc corrupted file when the 6.32 to 6.3.3 upgrade was made (ubuntu FF). Result was: cant open/load the file
, and the recovery box was empty.
That same ods still was loaded as expected on 6.07 calc version but failed on 6.3.3/4.
After tested a zip repair (on a ods copy indeed), the problem was persisting. Then i installed gnumeric, and the ods was opened as expected, did some minor data update, save and close the file.

Next i try again to load/open it with 6.34, and surprised, it was ok !!!
Only got a depracated look and fell sheet, but all data/formula was not damaged.

Did some formulas tweaks: spaces was removed between 'formula1'+'formula2'+ ...
so readded them for better readability; readjusted some font size elsewhere; and finally got back the original look & feel.

Looks like the new 'mutter' used on ubuntu FF put some trouble, like copy/paste   not working on the first try (paste a frame ui instead of the copied value/data); this is reported and asked multiple times from all distributions and 6.3.3/4 at least. Concern Calc / Writer and else.

Hopes devs will pay attention at that new mutter (3.34 +) and adapt/recompile to support the new design/feature
Comment 6 Timur 2020-03-31 07:31:07 UTC
Repro in Ubuntu 18.04.
Comment 7 Eike Rathke 2020-03-31 16:13:47 UTC
Mutter is nonsense,
Comment 8 Eike Rathke 2020-03-31 16:16:00 UTC
Created attachment 159190 [details]
crash backtrace

Problem with chart listener during import, mpToken pointing to invalid memory.
Comment 9 Timur 2020-04-01 05:22:58 UTC
Xisco, please see for regression.
Comment 10 Xisco Faulí 2020-04-01 09:07:49 UTC
it crashes in

Version: 7.0.0.0.alpha0+
Build ID: 169a10f0e4680814145b668c6320be04038d7a89
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 11 Caolán McNamara 2020-11-18 17:15:23 UTC
saw this document appear in a crashtesting run

https://gerrit.libreoffice.org/c/core/+/106061 to assert where it initially goes wrong
https://gerrit.libreoffice.org/c/core/+/106066 as a plausible solution
Comment 12 Commit Notification 2020-11-19 08:49:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f854e62a9d21f7874390952491ba38ed3056edd0

crashtesting: assert the failure which will cause tdf129410-1.ods to crash

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-11-19 08:49:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4198d04df49cff31f509b219293e5e18f7499e05

crashtesting: make tdf129410-1.ods not crash on load

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Caolán McNamara 2020-11-19 08:55:47 UTC
seems fixed in master now, backport to 7-0 in gerrit
Comment 15 Xisco Faulí 2020-11-19 11:18:30 UTC
Verified in

Version: 7.1.0.0.alpha1+
Build ID: 2f7b5634487ac3d27777ab12a57089e71ea5216d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 16 Commit Notification 2020-11-19 19:50:01 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0277c2c57f3990cb9078f11d0969faa1fb21a9d1

tdf#129410: sc_subsequent_filters: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-11-25 13:46:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/153a3587461ba8f14ac849d2f99d3985c0138cf3

crashtesting: make tdf129410-1.ods not crash on load

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.