Download it now!
Bug 129411 - Notebookbar context-Printpreview crash LO writer
Summary: Notebookbar context-Printpreview crash LO writer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2019-12-15 07:59 UTC by andreas_k
Modified: 2020-01-07 16:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-12-15 07:59:54 UTC
If you have select any Notebookbar layout in writer and go to printpreview libreoffice writer crash.

in calc it didn't crash
in standard toolbar layout it didn't crash

tested with
Version: 6.5.0.0.alpha0+
Build ID: 113444f59dc7690850919155b9b164b1a686bbe7
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-12-14_05:23:58
Locale: de-AT (de_AT.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 raal 2019-12-15 11:51:49 UTC
Confirm with Version: 6.5.0.0.alpha0+
Build ID: c50b4cb4b69597400a8325e0a200c95cf41c62f0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 2 raal 2019-12-15 12:08:11 UTC
This seems to have begun at the below commit.
Adding Cc: to Muhammet Kara ; Could you possibly take a look at this one?
Thanks

d4f537fee7ecb1bbb43dc84cba7da914372cb00e is the first bad commit
commit d4f537fee7ecb1bbb43dc84cba7da914372cb00e
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Nov 27 01:36:21 2019 +0100

    source sha:2d01ed9e8be543460e41e009fa992103a7c8d4c0

author	Muhammet Kara <muhammet.kara@collabora.com>	2019-11-25 21:55:31 +0300
committer	Muhammet Kara <muhammet.kara@collabora.com>	2019-11-26 15:39:56 +0100
commit	2d01ed9e8be543460e41e009fa992103a7c8d4c0 (patch)
tree	bd75130e564374647046f03ad4a334c1876d9dd0
parent	9b6b134b3e605236e90aca089867f08d659a6076 (diff)
tdf#94288: Show chart props sidebar on activation
Comment 3 Mike Kaganski 2020-01-06 11:56:04 UTC
Should be accidentally fixed with https://git.libreoffice.org/core/+/afa6a774936c34b09b37ab8539193ac529681798
Comment 4 Xisco Faulí 2020-01-07 15:58:24 UTC
(In reply to Mike Kaganski from comment #3)
> Should be accidentally fixed with
> https://git.libreoffice.org/core/+/afa6a774936c34b09b37ab8539193ac529681798

Indeed, the issue is fixed in

Version: 6.5.0.0.alpha0+
Build ID: bf540873f5e258452fed5006f65a403c95e7872a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike, thanks for fixing this issue!
Comment 5 andreas_k 2020-01-07 16:00:29 UTC
(In reply to Mike Kaganski from comment #3)
> Should be accidentally fixed with
> https://git.libreoffice.org/core/+/afa6a774936c34b09b37ab8539193ac529681798

many thanks