Bug 129415 - Writer: help links in Options Dialog have wrong target
Summary: Writer: help links in Options Dialog have wrong target
Status: RESOLVED DUPLICATE of bug 129904
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog Help-Link
  Show dependency treegraph
 
Reported: 2019-12-15 17:17 UTC by Timur
Modified: 2020-01-20 12:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2019-12-15 17:17:09 UTC
Tools-Options-Writer-Print opens wrong help:
https://help.libreoffice.org/6.5/en-US/text/shared/optionen/java.html
(there's https://help.libreoffice.org/6.5/en-US/text/shared/01/04050000.html)

I'll confirm for this, as noticed in bug 122706.
But we should check all Options dialog help here.
Comment 1 Gabor Kelemen 2019-12-15 22:53:41 UTC
This may be the same problem as bug #94503 - which I don't see anymore in GTK3 vclplug, but its still present with QT5 and gen.

You did only click on the left treeview and not inside the tab itself?

Also it is useful to set the environment variable HELP_DEBUG to true and enable extended help on Options - General page. 
That should put the HID into the extended tooltips bubble (if offline help is present) which then can be looked up in the helpcontent2 git repository.
Comment 3 Timur 2019-12-24 10:04:27 UTC
(In reply to Gabor Kelemen from comment #1)
> You did only click on the left treeview and not inside the tab itself?
If I click just on the left treeview, I see general Writer help.
If I click in the tab itself, I see Advanced help.
So both are wrong.

Dieter, when documentation needs to be updated, it's Documentation.
Here, Writer needs to be updated, so I set back component.
Comment 4 Xisco Faulí 2020-01-20 12:05:51 UTC
in

Version: 6.5.0.0.alpha0+
Build ID: fc1f85127968d1c2e0a53dace51bf8a78f9e6ca5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

it opens https://help.libreoffice.org/6.5/en-US/text/shared/optionen/01040400.html?System=UNIX&DbPAR=WRITER&HID=modules/swriter/ui/printoptionspage/PrintOptionsPage#bm_id3153750

dupe of bug 129904

*** This bug has been marked as a duplicate of bug 129904 ***