Download it now!
Bug 129446 - Slide Pane: Context menu is not displayed under certain conditions (gen)
Summary: Slide Pane: Context menu is not displayed under certain conditions (gen)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.3.6
Keywords: bibisected, bisected, regression
: 130082 (view as bug list)
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2019-12-17 12:20 UTC by Xisco Faulí
Modified: 2020-02-24 15:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-12-17 12:20:34 UTC
Steps to reproduce:
1. Open Impress
2. Undock the slide pane
3. Right click on the slide -> Context menu is displayed
4. Move the slide pane somewhere else
5. Right click onthe slide again

-> Nothing happens

Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: f86824cca0c442d371379d2ea0bff2241f18ab3d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-12-17 12:21:45 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d8f0e4144d51ff5709d005d289d71aa32f323913

author	Caolán McNamara <caolanm@redhat.com>	2017-11-03 16:24:14 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2017-11-04 00:42:24 +0100
commit	d8f0e4144d51ff5709d005d289d71aa32f323913 (patch)
tree	c07b13c961538ad0635725677e21469f030d8376
parent	5228db64eb9f55c945f1b460f2955fc3edfad791 (diff)
Resolves: rtl: tdf#60315 slide pane context menu misplaced

Bisected with: bibisect-linux64-6.0

Adding Cc: to Caolán McNamara
Comment 2 Xisco Faulí 2020-02-18 16:32:12 UTC
*** Bug 130082 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2020-02-19 14:05:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/035a5a419b92bf00973d67755d32126c6a36d6fa

Resolves: tdf#129446 explicitly pass the mouse event window

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2020-02-19 14:10:36 UTC
fixed in master, backport to 6-4 in gerrit
Comment 5 Xisco Faulí 2020-02-24 11:46:14 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: f32a59a52e3ee2a0a8df9bb76bc1ff0ada7c7f1d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 6 Commit Notification 2020-02-24 11:47:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/8130bd0bd25db1d9b0517b08c40640f3a96aea2b

Resolves: tdf#129446 explicitly pass the mouse event window

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-02-24 15:45:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/ef8d3dbc1126923e1b08f528f0eab5b980d97876

Resolves: tdf#129446 explicitly pass the mouse event window

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.