Download it now!
Bug 129465 - Form in LO Base: Text and option are not at the same level
Summary: Form in LO Base: Text and option are not at the same level
Status: RESOLVED DUPLICATE of bug 129491
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Base-UX
  Show dependency treegraph
 
Reported: 2019-12-18 09:42 UTC by Vera Blagoveschenskaya
Modified: 2019-12-20 09:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
scr (40.62 KB, image/png)
2019-12-18 09:43 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2019-12-18 09:42:55 UTC
Description:
Form in LO Base: Text and option are not at the same level 

Steps to Reproduce:
1. Create new default database.
2. Forms -> Create new form
3. Add Option button

Actual Results:
Text and option are not at the same level - see screen

Expected Results:
Correct view (text and button are at the same level)


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for

Version: 6.5.0.0.alpha0+
Build ID: 3e33a11d8a553a99bd5f23940a65c301924198fb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-12-16_11:03:40
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Also reproduced for

Version: 6.4.0.0.alpha0+
Build ID: 1496a1831d1be0a2d24be9fe3ecf627b2664e938
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-09-04_14:52:26
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

DO NOT reproduce for earlier LO version

Version: 6.3.0.0.alpha1+
Build ID: 77ae0abe21f672cf4b7d2e069f1d40d20edc49a7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-31_15:33:33
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Vera Blagoveschenskaya 2019-12-18 09:43:11 UTC
Created attachment 156644 [details]
scr
Comment 2 Julien Nabet 2019-12-18 10:47:05 UTC
On Win10 with master sources updated today, I could reproduce this.
Comment 3 Julien Nabet 2019-12-18 10:56:21 UTC
Adding some traces searching for "RID_STR_PROPTITLE_RADIOBUTTON" shows these code pointers to start:
https://opengrok.libreoffice.org/xref/core/svx/source/form/formcontrolfactory.cxx?r=44a6335f#473

https://opengrok.libreoffice.org/xref/core/svx/source/form/formcontrolfactory.cxx?r=44a6335f#648
Comment 4 Julien Nabet 2019-12-18 11:06:53 UTC
On Win10 with 6.3.4 LO + brand new profile, I don't reproduce this.
=> regression.
Comment 5 Xisco Faulí 2019-12-19 10:56:47 UTC

*** This bug has been marked as a duplicate of bug 129491 ***
Comment 6 Sebastian Morris 2019-12-20 09:17:14 UTC
Looking forward to reading more. Great blog.Thanks Again. Much obliged.
http://survey-guide.com/footactionsurvey-com-foot-action-survey/