Bug 129493 - Inserting of hyperlink into cell adds net address near text in cell instead adding a hyperlink to existing text in cell
Summary: Inserting of hyperlink into cell adds net address near text in cell instead a...
Status: RESOLVED DUPLICATE of bug 80043
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2019-12-19 11:27 UTC by Roman Kuznetsov
Modified: 2019-12-19 12:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-12-19 11:27:37 UTC
Description:
Inserting of hyperlink into cell adds net address near text in cell instead adding a hyperlink to existing text in cell

I see two variants for fix it:

1. Hyperlink dialog doesn't open if select only cell (cell range). It should be open only if text in cell is selected
2. If cell has any text inside, then Hyperlink dialog should have that text in field "Text:" and it should producee a hyperlink from existing text inside cell.

Steps to Reproduce:
1. Create a new spreadsheet in Calc
2. Enter to A1 cell "AAA"
3. Select B1 cell, then select A1 cell again
4. Press Ctrl+K on keyboard
5. In the Hyperlink dialog enter any URL, like AAA.com, then press OK
6. Calc adds AAA.com near existing AAA text in cell

Actual Results:
Calc adds AAA.com near existing AAA text in cell

Expected Results:
Calc makes from AAA text a hyperlink with AAA.com address inside


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.5.0.0.alpha0+ (x64)
ID сборки: ff566c67d67e96c97bcf4064b39df6998733c84e
Потоков ЦП: 4; ОС:Windows 10.0 Build 18362; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 1 Heiko Tietze 2019-12-19 12:32:01 UTC
Option #2 has been reported and is the best solution.

*** This bug has been marked as a duplicate of bug 80043 ***