Download it now!
Bug 129549 - Bullet and Numbering icon appears twice in Customize Toolbars
Summary: Bullet and Numbering icon appears twice in Customize Toolbars
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.5.0
Keywords:
Depends on:
Blocks: Customize-Dialog-Toolbars
  Show dependency treegraph
 
Reported: 2019-12-22 13:21 UTC by sdc.blanco
Modified: 2020-01-08 05:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2019-12-22 13:21:32 UTC
To see problem:

1.  Tools > Customize - Toolbars tab
2.  In search field, write: "bul"

Actual Result:  Bullets and Numbering Appears twice

Expected result: ?? 

Additional information:

1. From registry information, probably one icon is for:

.uno:BulletsAndNumberingDialog (from UI.WriterCommands)

while the other is for:

.uno:OutlineBullet   (from UI.GenericCommands)

2.  Added both icons to a toolbar, tested, seem to give same result.

3.  This report is made in case someone thinks there is a problem such as:
(a) the icons should be different
(b) there was an intention for these two uno commands to have a different effect
(c) maybe the source code can/should be unified here
Comment 1 sdc.blanco 2019-12-22 13:30:10 UTC
also produced in: Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
Comment 2 Xisco Faulí 2019-12-26 15:40:33 UTC
Thanks for reporting this issue.
This is a duplicate of bug 108458

*** This bug has been marked as a duplicate of bug 108458 ***
Comment 3 sdc.blanco 2019-12-26 18:14:11 UTC
(In reply to Xisco Faulí from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 108458 ***

Presumably you are sure this is a duplicate -- but it looked like the recent fix to bug #108458 concerned showing tooltips -- and no mention about Bullets and Numbering.  No need for reply if this correct.
Comment 4 Mike Kaganski 2020-01-01 09:13:26 UTC
This is not a duplicate.

Yes, these two UNO commands do exactly the same. Having different names, and different slots (.uno:BulletsAndNumberingDialog maps to FN_NUMBER_BULLETS, and  .uno:OutlineBullet to SID_OUTLINE_BULLET), when in Writer, they both are routed to SwTextShell::ExecEnterNum, where they are treated identically. The difference between them is only that there is a code handling SID_OUTLINE_BULLET also in sd, while FN_NUMBER_BULLETS is specific only to sw. Thus, the latter is better deprecated (although kept for compatibility) and made hidden, so that it doesn't appear in the customization UI.
Comment 5 V Stuart Foote 2020-01-01 17:53:27 UTC
The .uno commands are unique. The label is duplicated, that was the crux of bug 108458 --ambiguity with the labels. That is resolved with details in the tooltip.

Icons for the duplicated .uno commands may or maynot be reused. On Windows builds of master/6.5.0 and 6.4.0.1 a search for "bul" shows different icons for Colibre, Breeze, Sifr, and Elemenatry icon themes. Just Tango & Karasa Jaga themes reuse the icon.
Comment 6 Mike Kaganski 2020-01-01 19:21:59 UTC
(In reply to V Stuart Foote from comment #5)

I'm sorry: specifically what is WONTFIX here? The bug is not about distinct *icons* here: it's about two *identical* elements in the command list. The names of uno commands are different - but they are doing absolutely the same, absolutely the same. What is the purpose to have those *two* entries for one function? They are not two functions with one name, but different actions.

I disagree with WONTFIX.
Comment 7 V Stuart Foote 2020-01-01 19:40:50 UTC
@Mike, understand these UNO controls happen to have same end result and could be unified (or one hidden), but the search of controls in the customization dialog is generic--a search pulls in entries from all components. 

The "bul" search here is just one of multiple that can return 'Label' matches from widgets intended for different modules. Try "incre" or "decre"

Do you really want to keep this open to factor in target module for the widget search in the customize dialog?

IMHO search results and duplicate labels made this a duplicate of bug 108458, and doing more with search in the Customize... dialog isn't worth it. => WF.
Comment 8 Mike Kaganski 2020-01-01 20:19:11 UTC
I believe that this issue is strictly about two correctly identified duplicates, one of which should be hidden - that's a good small target.
Comment 9 V Stuart Foote 2020-01-01 20:45:36 UTC
(In reply to Mike Kaganski from comment #8)
> I believe that this issue is strictly about two correctly identified
> duplicates, one of which should be hidden - that's a good small target.

I don't believe that was the nut of the issue for OP here.

And its not really broken nor an incorrect duplication in UNO, is it?

But your call as always...
Comment 11 Mike Kaganski 2020-01-05 17:58:34 UTC
https://gerrit.libreoffice.org/c/core/+/86245
Comment 12 Commit Notification 2020-01-06 15:34:44 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d1133d71a6109d1999121fd6a91573d12dc4852b

tdf#129549: hide .uno:BulletsAndNumberingDialog from customization UI

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 sdc.blanco 2020-01-07 23:09:45 UTC
Confirmed.  Only one Bullets and Numbering appears now.  Looks better. Less confusing.  Thanks.  Maybe the status should be changed to Verified Fixed?

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 035c7717c135c66c0ec025500b73ae9c13b7c586
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: da-DK (en_DK); UI-Language: en-US
Calc: threaded
(7. jan 2020 build)