Download it now!
Bug 129563 - Cannot Cut and Paste Picture from MS Office Products Into Writer
Summary: Cannot Cut and Paste Picture from MS Office Products Into Writer
Status: RESOLVED DUPLICATE of bug 99507
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-23 09:35 UTC by Paul Connacher
Modified: 2019-12-23 12:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCUMENTS USED FOR THIS TEST (549.35 KB, application/x-zip-compressed)
2019-12-23 09:35 UTC, Paul Connacher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Connacher 2019-12-23 09:35:27 UTC
Created attachment 156742 [details]
DOCUMENTS USED FOR THIS TEST

Attempted to cut and paste a picture from Word, Powerpoint and Publisher into Writer document.

Normal Paste command from right-click menu does nothing although it is enabled.

Edit -> Paste command does nothing; although enabled.

Edit -> Paste Special -> GDI command works.

Edit -> Paste Special -> BMP command does not paste the image.

Edit -> Paste Special -> Paste Unformatted Text command is available in both the Edit menu and in the right-click popup menu but i am attempting to paste image into the Writer document and not text.

Windows in use is Windows 10 Pro 64-bit version 1909.

Office in use is Office Pro Plus 2019.

LibreOffice in use is 6.4.01 64-bit.

I have attached a ZIP file containing the documents used in this test.
Comment 1 Roman Kuznetsov 2019-12-23 10:49:38 UTC
confirm in

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

and in

Версия: 5.2.7.2
ID сборки: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
Потоков ЦП: 4; Версия ОС: Windows 6.2; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU); Calc: group
Comment 2 Roman Kuznetsov 2019-12-23 10:50:16 UTC
(In reply to Roman Kuznetsov from comment #1)
> confirm in
> 
> Version: 6.5.0.0.alpha0+ (x64)
> Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
> CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
> Locale: ru-RU (ru_RU); UI-Language: en-US
> Calc: threaded
> 
> and in
> 
> Версия: 5.2.7.2
> ID сборки: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
> Потоков ЦП: 4; Версия ОС: Windows 6.2; Отрисовка ИП: по умолчанию; 
> Локаль: ru-RU (ru_RU); Calc: group

MS Office 2013
Comment 3 Thomas Lendo 2019-12-23 12:06:45 UTC
Seems to be a duplicate of an older bug.

*** This bug has been marked as a duplicate of bug 99507 ***