Bug 129679 - When validating a cell as cell range I click on the source field, it results in only being capable of select cells and nothing more.
Summary: When validating a cell as cell range I click on the source field, it results ...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-29 05:22 UTC by kodaichi_san
Modified: 2022-07-18 02:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kodaichi_san 2019-12-29 05:22:35 UTC
Description:
When I try to validate a cell as a cell range if I click on the input space to write a formula the validation windows disappears and then I only can select cells in the spreadsheet, the program doesn't let me do anything more. Sometimes I even can't select cells.

Here is a video I recorded just in case: https://youtu.be/YeWEdT9PJuo

One thing I tried was restart Calc in safemode. In safemode I can validate a cell as a cell range and can write on the input space, but if I try to edit the validation of that cell it becomes bugged again(sometimes I can edit it just one time as the video shows, if I try to do so for a second time it becomes bugged).

Again here is a video I recorded: https://youtu.be/qinu9QCb9Qc

In both cases the only way to close Clac is killing the process from the terminal.

Steps to Reproduce:
1. Select a cell.
2. Data > Validity.
3. In Criteria choose 'cell range'
4. Click in the source field.

Actual Results:
The validity windows disappears and then you only can select cells and nothing more.

Expected Results:
I should be able to write in the 'source' field.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
* In safe mode sometimes you can actually click in the source field and write and click 'Ok' but then when you try to edit the validation and try to write on the source field it becomes bugged again.

----------------

Version: 6.2.8.2
Build ID: 6.2.8-3
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kde5; 
Locale: es-ES (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 m.a.riosv 2019-12-29 17:32:57 UTC
I can't repro
Version: 6.2.8.1 (x64)
Build ID: 815fe723fb0e60e4a39ff860f907cc63980a0232
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: 
Versión: 6.3.4.2 (x64)
Id. de compilación: 60da17e045e08f1793c57c00ba83cdfce946d0aa
Subprocs. CPU: 4; SO: Windows 10.0; Repres. IU: GL; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES Calc: CL
Comment 2 Stanislaus J. Pinasthika 2020-02-01 00:33:34 UTC
Thanks for reporting the problem, I am sorry, I can't reproduce it in Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 6.5.0.0.alpha0+
Build ID: 5030be4e85179147476b1e441eb618fb6ed58235
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-28_20:14:48
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded

I suggest you to update your LibreOffice to newest version, thank you
Comment 3 Buovjaga 2020-05-02 16:26:44 UTC
Yep, please try with a newer version. An appimage is an easy possibility to test: https://libreoffice.soluzioniopen.com/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 QA Administrators 2020-10-30 04:13:54 UTC Comment hidden (noise)
Comment 5 QA Administrators 2020-11-30 03:47:39 UTC Comment hidden (noise)
Comment 6 Commit Notification 2022-06-19 18:42:33 UTC
Laurent Balland committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/76523322affd4d47952dfcfe0a6822c3d746ffa5

Update tdf#129679
Comment 7 Commit Notification 2022-07-18 02:04:23 UTC
Laurent Balland committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/help/commit/3aa14c1380baae3f739cddfde106764192c1bcb7

Update tdf#129679