Bug 129699 - EDITING “Paste special - Unformatted text” does not overwrite content with empty cell
Summary: EDITING “Paste special - Unformatted text” does not overwrite content with em...
Status: RESOLVED DUPLICATE of bug 129701
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Paste-Special
  Show dependency treegraph
 
Reported: 2019-12-30 13:54 UTC by NISZ LibreOffice Team
Modified: 2020-01-06 12:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Calc (9.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-12-30 13:55 UTC, NISZ LibreOffice Team
Details
The Text Import dialog before pasting (44.44 KB, image/png)
2019-12-30 13:55 UTC, NISZ LibreOffice Team
Details
The file after pasting with A3 not becoming empty (59.54 KB, image/png)
2019-12-30 13:55 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-12-30 13:54:18 UTC
Description:
When copying and pasting a cell range in Calc that contains an empty cell, the empty cell does not overwrite preexisting content in target cell range.

Steps to Reproduce:
1.	Open the attached simple Calc table with some text in A1:A4 and in B1:B4 with B3 empty.
2.	Copy the B1:B4 range and paste it while standing on A1 with Paste Special -> Unformatted text.
3.	The Text Import dialog shows and the preview shows that the third cell would be empty. Click OK.


Actual Results:
The third cell is not overwritten with the empty cell.

Expected Results:
(1) The normal Ctrl-V paste would overwrite A3 with the empty cell content in B3. 
(2) The user who reported this issue expects that Paste Special -> Unformatted text would also empty the cell. This does not happen, because the Text Import window has a “Skip empty cells” option that is turned on by default. Also: turning it off does not seem to make a difference, that might be another bug.
(3) The “no overwrite with empty cell” result could be achieved by enabling the Paste Special dialogs Skip empty cells option. “Skip empty cells” is off by default so using Paste Special -> Paste Special and only pasting Text, Numbers, Date & time gives also the same result as in (1).

To sum it: options (1) and (3) are overwriting the cell content by default, but (2) does not. I’m not sure whether this is intentional or not. 
Syncing the default setting of “Skip empty cells” between the Text Import and Paste Special dialogs would be a solution to this.



Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 0ad51b30556f96bff0d78cc540781416c1ea6b8b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

Also happens in:
Verzió: 6.0.0.3
Build az.: 64a0f66915f38c6217de274f0aa8e15618924765
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; 
Területi beállítások: hu-HU (hu_HU); Calc: CL

Verzió: 4.0.0.3 (Build az.: 7545bee9c2a0782548772a21bc84a9dcc583b89)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 1 NISZ LibreOffice Team 2019-12-30 13:55:03 UTC
Created attachment 156845 [details]
Example file from Calc
Comment 2 NISZ LibreOffice Team 2019-12-30 13:55:22 UTC
Created attachment 156846 [details]
The Text Import dialog before pasting
Comment 3 NISZ LibreOffice Team 2019-12-30 13:55:42 UTC
Created attachment 156847 [details]
The file after pasting with A3 not becoming empty
Comment 4 m.a.riosv 2019-12-31 07:52:55 UTC
Repro
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 5 m.a.riosv 2019-12-31 07:55:23 UTC

*** This bug has been marked as a duplicate of bug 129701 ***
Comment 6 Heiko Tietze 2020-01-06 12:40:49 UTC
Don't see this as a duplicate but also cannot reproduce.

A B
1 5
  2 
3 6
4 7

copy A over B clears the 2.