Download it now!
Bug 129725 - Dark theme for the welcome window.
Summary: Dark theme for the welcome window.
Status: RESOLVED DUPLICATE of bug 99116
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, difficultyInteresting, easyHack, skillCpp, topicDesign
Depends on:
Blocks:
 
Reported: 2020-01-01 22:23 UTC by Thomas Leigh
Modified: 2020-02-26 12:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Start center using Breeze Dark theme (282.70 KB, image/png)
2020-01-22 09:55 UTC, Heiko Tietze
Details
Simple solution (75.08 KB, image/png)
2020-01-22 13:57 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Leigh 2020-01-01 22:23:07 UTC
Description:
It’s crucial for Me to apply a dark GUI wherever I can, due to my vision (pretty hard to handle anything bright). I am very happy that I was able to dark-theme many areas of LibreOffice GUI (Windows). I also much like the idea of the welcome window (the one where You see recent documents, have access to the templates, and so on). I find it fantastic, mainly because it’s much more readable than, say, Windows 7 jump lists (in Libre Office I need only to throw an eye on the window and it’s clear which document is which - thanks to thumbnails big enough - I don’t even need to read their names).

The only thing which is difficult for me is that this window is bright regardless of applying dark theme. It’s a pain for the eyes.

Could it be possible or could You please make it possible to dark-theme also this window?


-- 
Thank You for Your time,
Kind regards,
Thomas Leigh

Actual Results:
Bright start screen.

Expected Results:
Dark-themed start screen.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Thomas Leigh 2020-01-16 12:11:48 UTC
> QA:needsComment 

What comment do You need? How can I help?
Comment 2 Heiko Tietze 2020-01-22 09:54:24 UTC
(In reply to Thomas Leigh from comment #1)
> What comment do You need? How can I help?

This is an automated message requesting a comment from the QA team in order to quickly respond to tickets.

About the start center: it is not really bright. What exactly do you wish to change?
Comment 3 Heiko Tietze 2020-01-22 09:55:17 UTC
Created attachment 157314 [details]
Start center using Breeze Dark theme
Comment 4 Thomas Leigh 2020-01-22 12:23:45 UTC
(In reply to Heiko Tietze from comment #2)
> (In reply to Thomas Leigh from comment #1)
> > What comment do You need? How can I help?
> 
> This is an automated message requesting a comment from the QA team in order
> to quickly respond to tickets.
> 
> About the start center: it is not really bright. What exactly do you wish to
> change?

I’d like the sidebar to be dark or - the best - black, as well as the background on the top of which recent documents are placed (see the screenshot: https://drive.google.com/file/d/1NPSUGRUADW-zfVSySsTfZ-bVHKQf3bbu/view?usp=sharing ).
Comment 5 Thomas Leigh 2020-01-22 12:24:23 UTC
(In reply to Heiko Tietze from comment #3)
> Created attachment 157314 [details]
> Start center using Breeze Dark theme

I don’t have “the Breeze Dark Theme” - a have the following preinstalled themes: “White”, “Gray”, “Dark” (which I use), “Pink”, “Sand” and “Green”.
Comment 6 Heiko Tietze 2020-01-22 13:57:31 UTC
Created attachment 157327 [details]
Simple solution

The start center has capabilities to change the color via expert configuration. Use Tools > Options > Advanced > Expert and search for StartCenterBackgroundColor and StartCenterBackgroundColor and StartCenterTextColor. I used 0 (black) and 16777215 (white; decimal for the hex value of #ffffff) in the example with a small patch to apply the color to the whole area (mpButtonsBox->SetBackground(aButtonsBackground); in BackingWindow::initControls()).
Furthermore we have a decorative image that can be designed per icon theme (karasa jaga and elementary have a different bitmap).

So the question is if we want to keep this strange configurability or use the system default value.
Comment 7 Heiko Tietze 2020-01-22 13:58:16 UTC
Kendy, was there any reason not to use system default?
Comment 8 Thomas Leigh 2020-01-22 14:19:16 UTC
(In reply to Heiko Tietze from comment #6)
> Created attachment 157327 [details]

Thank You very much. Now I’ve achieved a dark sidebar. What about the background on top of which the recent documents are placed? You’ve said:

> with a small patch to apply the color to the whole area (mpButtonsBox->SetBackground(aButtonsBackground); in BackingWindow::initControls()). Furthermore we have a decorative image that can be designed per icon theme (karasa jaga and elementary have a different bitmap).

I am not sure should this is something I should do... I’ve searched the expert settings for the “mpButtonsBox” string, but I don’t find it.


> So the question is if we want to keep this strange configurability or use the system default value.

It would be fantastic to have those options available within standard settings window (with no need to play with the expert mode). Or (even better) to allow themes to affect the start center (this way we could achieve a more coherent appearance).
Comment 9 Thomas Leigh 2020-01-22 14:19:47 UTC
(In reply to Heiko Tietze from comment #7)
> Kendy, was there any reason not to use system default?

In case of users who find a dark theme important, system default may be not enough - I, for example, use a custom dark theme under Windows 7, which, however, does not affect the LO start center at all.
Comment 10 Heiko Tietze 2020-01-22 14:23:46 UTC
(In reply to Thomas Leigh from comment #8)
> What about the background on top
The menu should receive colors from the OS. It's a different topic anyway.

> I am not sure should this is something I should do...
No, it's a small patch at the source code that needs to be done anyway to make things working. But it's pointless to submit this patch only when we decide to drop the customization of colors.

> ... allow themes to affect the start center
Would be cool, indeed.
Comment 11 Thomas Leigh 2020-01-22 14:28:20 UTC Comment hidden (off-topic)
Comment 12 Heiko Tietze 2020-01-22 14:32:13 UTC Comment hidden (off-topic)
Comment 13 Thomas Leigh 2020-01-22 14:37:24 UTC Comment hidden (off-topic)
Comment 14 Heiko Tietze 2020-01-22 14:49:09 UTC Comment hidden (off-topic)
Comment 15 V Stuart Foote 2020-02-18 21:50:16 UTC
(In reply to Heiko Tietze from comment #6)
> ...
> So the question is if we want to keep this strange configurability or use
> the system default value.

(In reply to Heiko Tietze from comment #7)
> ... was there any reason not to use system default?

It was a developers choice that followed branding in replacing the OOo era launch panel. IIRC the fixed colors of the Start Center were hardcoded to make it consistent across the os/DE builds rather than theming.

That and it is difficult on Windows and macOS to extract os/DE theming to apply to UI elements--we don't get passed everything we'd need from the theme.

We already had to tweak special case of HC support (bug 71511) where LibreOffice detects a11y support and responds--but LO still has glitches when toggling the os/DE between modes, annoying.

Likely the whole theming framework needs refactoring to do this smoothly, native WinRT/UWP support and Cocoa APIs. 

Controlling the 'white' backing window of the StartCenter would support the a11y needs of OP. But work on theming is also needed for the newer DE modes now offered on Windows (bug 118320) and macOS (118017).
Comment 16 Heiko Tietze 2020-02-20 09:46:48 UTC
We discussed the topic in the design meeting and agree that, if possible, we drop the variable in favor of system values or alternatively the application colors (eg. application background and document background).

Easyhack, code pointer in c6.
Comment 17 Heiko Tietze 2020-02-26 12:10:31 UTC

*** This bug has been marked as a duplicate of bug 99116 ***