Bug 129735 - Provide functionality to move sections
Summary: Provide functionality to move sections
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2020-01-02 11:12 UTC by peter josvai
Modified: 2020-01-17 07:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2020-01-02 11:12:57 UTC
Description:
'sections' works very well, and it is apparently pretty well thought up, with a depth of complexity... I love it, too :)

what would be great to allow the user to MOVE a section... within the document...

to MOVE or to DELETE it...

all this available from a context menu

Steps to Reproduce:
1. try to move a section
2.
3.

Actual Results:
you'll have to go "edit section", remove it.. then select the text in the document (left there by remove), and delete it..

Expected Results:
right click in section,
choose:
"move this section"
(this would make the section's text shrink to the anchor where it it linked, that is, the text would disappear and occupy no space in the text)

than you could click anywhere in the document, 
which would popup: "place section here?" with options: place it, no, cancel

and where you choose "place it", it would be there



Reproducible: Always


User Profile Reset: No



Additional Info:
working with sections belongs to the realm of complex texts and sophisticated editing...

in which moving a section seems to be something basic that should work

(One would even expect to be able to move sections when seeing the "section edit" dialogue, with sections listed one under the other -- which makes us think that a "move up/down" operation is available -- BUT of course, it is understood that this would not be a wise thing, since sections can be surrounded with body text, too... and not only by other sections)
Comment 1 peter josvai 2020-01-02 11:16:37 UTC
in addition to "MOVE" (this section), a "DELETE" (this section) menu item would be good in the same context menu..

which would remove the linking and the section (as 'remove' does), AND the linked text from the body text...
Comment 2 Roman Kuznetsov 2020-01-02 15:42:50 UTC
So possibly would be good to have opportunity "Cut section", "Copy section" and "Paste section".

UX-team?
Comment 3 Heiko Tietze 2020-01-07 15:45:49 UTC
Same argument as on bug 129733, adding more functionality is tempting but changes the scope of sections from just a formatting object towards a content handler.

If we implement this, I would expect it at the Navigator and similarly the sections dialog, eg. per arrow button up/down.
Comment 4 Cor Nouws 2020-01-16 21:39:03 UTC
(In reply to peter josvai from comment #0)
> what would be great to allow the user to MOVE a section... within the
> document...
If you select a section including paragraph on top and below, copy, cut, delete work as expected. So you can copy/paste as you like.

> WFM
Comment 5 Heiko Tietze 2020-01-17 07:15:02 UTC
We discussed this topic in the design meeting and decided to add standard functionality to section. In respect to move it's a bit unclear though since moving could mean a paragraph, a chapter, or to swap sections. As Cor pointed out, you have cut/paste and by this more freedom.