Download it now!
Bug 129736 - LibreOffice can not save document if the path contains accents (Native dialog box) (KDE5 VCL only)
Summary: LibreOffice can not save document if the path contains accents (Native dialog...
Status: RESOLVED DUPLICATE of bug 130080
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-01-02 11:31 UTC by obook
Modified: 2020-02-05 12:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast where it works (6.85 MB, video/webm)
2020-01-09 06:58 UTC, Michael Weghorn
Details
Error LibreOffice (23.17 MB, video/mp4)
2020-01-09 11:06 UTC, Mian Riccardo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description obook 2020-01-02 11:31:18 UTC
Description:
An error appear during in save dialbox (LibreOffice dialbox not set) if the full path content accents.

Steps to Reproduce:
1. Create any LibreOffice document, with Options->General->Use LibreOffice dialog unset
2. Try to save it in path how content (french) accents
3. An error dialbox appear "Le dossier spécifié n'existe pas ou n'est pas lisible."
4. If you press Ok, the document is saved by default in ~/Documents folder.

Actual Results:
Is not possible to save the file in the correct folder.

Expected Results:
Saving in any path with accents (accepted by OS)


Reproducible: Always


User Profile Reset: No



Additional Info:
Path sample : /home/user/user@gmail.com/Hétérogénéité 28112019/
Comment 1 ian 2020-01-04 01:09:19 UTC Comment hidden (obsolete)
Comment 2 ian 2020-01-04 01:09:19 UTC Comment hidden (obsolete)
Comment 3 obook 2020-01-04 12:05:02 UTC
Please read "contains" (not content). Thx
Comment 4 obook 2020-01-04 22:18:35 UTC
LibreOffice can not save document if the path contains accents (Native dialog box). For example if the path is /home/user/user@gmail.com/Hétérogénéité 28112019/
Comment 5 ian 2020-01-05 02:24:23 UTC
I cannot seem to replicate the bug using an almost identical file-path to what was specified. 

Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 1; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threadedVersion: 6.3.4.2
Comment 6 obook 2020-01-05 11:22:09 UTC
-I have this bug only on 'Open', 'Save as' or PDF button from toolbar.
-I don't have this bug if settings are 'use Libreoffice dialogs'.
-I don't have this bug if I rollback to the previous LibreOffice version (6.0).

More steps for reproduce :
-create a folder with french accents (as /récupéré);
-move or copy a libreoffice odt file inside this folder;
-Launch LibreOffice Writer. From file menu, choice 'Open'
-Try to navigate to /récupéré folder

An error box appear 3 times : "Le dossier spécifié n'existe pas ou n'est pas lisible."

Version: 6.3.4.2
Build ID: 1:6.3.4-0ubuntu0.18.04.1~lo2
Threads CPU : 4; OS : Linux 5.0; UI Render : par défaut; VCL: kde5; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

Is it a bug with KDE/Plasma dialogs ? I use KDE Neon.
Comment 7 ian 2020-01-05 15:47:32 UTC
Thank you for providing additional information, specifically about your VCL. I attempted to reproduce the error using the additional steps you mentioned, and I was unable to do so. I never received any errors. I believe that the VCL, like you hinted at, is the issue.
Comment 8 Mian Riccardo 2020-01-08 16:43:26 UTC
Yes, the behavior indicated by "obook" is correct and occurs both using the "Open" menu and the "Save As" menu, while if you use "Save" everything works

I use OpenSuse 15.1 with KDE and LibreOffice 6.3.4.2
Comment 9 Ming Hua 2020-01-09 04:57:30 UTC
Let's ping the KDE meta bug and see if the KDE specialists have any ideas, then.
Comment 10 Michael Weghorn 2020-01-09 06:58:27 UTC
Created attachment 157032 [details]
Screencast where it works

I cannot reproduce on Debian testing with current master, s. attached screencast (using as path: /tmp/récupéré/test.odt).

Version: 6.5.0.0.alpha0+
Build ID: 08a0ede627fbf9bea42165c3de63812e469306b4
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

and I cannot reproduce with the version packaged by Debian either (package libreoffice 1:6.3.4-2).

Version of some possibly related KDE/KF5 packages:

ii  plasma-desktop 4:5.14.5.1-4
ii  libkf5kiocore5:amd64 5.62.1-2+b1
ii  libkf5kiofilewidgets5:amd64 5.62.1-2+b1
Comment 11 Michael Weghorn 2020-01-09 07:02:11 UTC
Some questions:

1) Do you get the problem when taking exactly the steps I took in the video? Any other ideas what else I might be missing?
2) Does it work for you with other KDE applications, e.g. kate?
3) Can you try whether using a current daily build from TDF makes any difference? Those are available at [1] and can be installed in parallel as described at [2].


[1] https://dev-builds.libreoffice.org/daily/master/
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 12 Mian Riccardo 2020-01-09 11:05:23 UTC
I added a video to highlight the error
Comment 13 Mian Riccardo 2020-01-09 11:06:12 UTC
Created attachment 157035 [details]
Error LibreOffice
Comment 14 Michael Weghorn 2020-01-21 14:31:27 UTC
(In reply to Mian Riccardo from comment #12)
> I added a video to highlight the error

Thanks. However, I'm still unable to reproduce. Can you possibly try to narrow this further down, e.g. using the questions from comment 11?
Comment 15 Buovjaga 2020-01-22 18:45:02 UTC
(In reply to Michael Weghorn from comment #14)
> (In reply to Mian Riccardo from comment #12)
> > I added a video to highlight the error
> 
> Thanks. However, I'm still unable to reproduce. Can you possibly try to
> narrow this further down, e.g. using the questions from comment 11?

Adding Mian to Cc.
Comment 16 Michael Weghorn 2020-02-05 12:03:31 UTC
This sounds like the same as bug 130080, which I could also reproduce on KDE Neon. Fix is pending in Gerrit.

Closing as duplicate. Please reopen in case you can still reproduce once bug 130080 is fixed.

*** This bug has been marked as a duplicate of bug 130080 ***