Bug 129800 - Change wording of PDF Export File encryption and Permission dialog in Writer for clarity
Summary: Change wording of PDF Export File encryption and Permission dialog in Writer ...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 129801 129802 (view as bug list)
Depends on:
Blocks: PDF-Export-Options-Dialog
  Show dependency treegraph
 
Reported: 2020-01-05 04:49 UTC by Tom Campbell
Modified: 2020-01-09 08:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen shot of the dialog in question (26.12 KB, image/png)
2020-01-05 04:49 UTC, Tom Campbell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Campbell 2020-01-05 04:49:37 UTC
Created attachment 156936 [details]
Screen shot of the dialog in question

When you export a Writer document to PDF, you can give it two different passwords, but the purpose of neither is as clear as it could be. Right now the options are:

Set open password

Set permission password

As you folks know, "open" means for opening the exported PDF. "permission" means a password on the actual .ODT document itself. Well, they're both "open" or "permission" passwords. How about this instead?

Set password on exported PDF

Set password on Writer document

Love OpenOffice, and yes, I contribute regularly. Thanks for an awesome job, peeps!
Comment 1 Julien Nabet 2020-01-05 07:55:51 UTC
*** Bug 129802 has been marked as a duplicate of this bug. ***
Comment 2 Julien Nabet 2020-01-05 07:56:04 UTC
*** Bug 129801 has been marked as a duplicate of this bug. ***
Comment 3 Roman Kuznetsov 2020-01-05 19:03:33 UTC
These passwords are both for PDF document. One for opening a PDF file and second for allowing of some actions for a PDF file like printing, editing, etc.

It think this enh is wontfix
Comment 4 Heiko Tietze 2020-01-06 10:20:55 UTC
Right now you click on Set Password, the dialog caption is Set Passwords, and the captions are "Set * password" - a bit redundant. And "permission" is a placeholder term without meaning. My proposal:

Set open password -> Read access
Set permission password -> Print/Change/Content access

Ideally we give access to the passwords at the same tab and get rid of the extra dialog.
Comment 5 Thomas Lendo 2020-01-07 21:23:53 UTC
(In reply to Heiko Tietze from comment #4)
> Set open password -> Read access
> Set permission password -> Print/Change/Content access
> 
> Ideally we give access to the passwords at the same tab and get rid of the
> extra dialog.
To get rid of the extra dialog would be indeed fantastic. The text below the 'Set passwords' button is doing something that isn't available anywhere else.

I'm not sure if a wording change will be clearer for the user. Users read as few text as they can (and not as few as appropriate) so the repetition may be OK in this place.

Maybe
Set open password for read access
Set permission password for change access
Comment 6 Roman Kuznetsov 2020-01-07 21:26:45 UTC
The best way here is just don't touch it. Current phrases are fully clear and correct for me.
Comment 7 Heiko Tietze 2020-01-09 08:41:43 UTC
Changes to the labels have little benefit (but some consequences for l10n). And the passwords are kind of explained on the parent dialog. So let's keep it as it is.