Download it now!
Bug 129846 - Missing Extra Large (32px*32px) Sifr Icons
Summary: Missing Extra Large (32px*32px) Sifr Icons
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:6.5.0 target:6.4.1
Keywords:
Depends on:
Blocks: Icon-Theme-Sifr
  Show dependency treegraph
 
Reported: 2020-01-07 05:58 UTC by Rizal Muttaqin
Modified: 2020-02-22 01:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Missing extra large Sifr icons in Writer (43.57 KB, image/png)
2020-01-07 05:58 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2020-01-07 05:58:07 UTC
Created attachment 156975 [details]
Missing extra large Sifr icons in Writer

Step to reproduce:

1. Change icon to Sifr with size extra large

Missing many 32px*32px icons in Sifr, and fallbacked to Breeze

Please add them
Comment 1 Commit Notification 2020-01-10 03:46:19 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7430664d2b9dc6f094f61e0ce9f4a3adbfcefe36

Sifr: Fix for tdf#127415, tdf#129846

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2020-01-14 19:23:48 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/de20525d6ff2078d25f2c8fffada6245e0824a77

Sifr: Add more 32px icons (tdf#129846)

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Boaz Dodin 2020-01-15 07:38:58 UTC
As 32px is not the default size and fallback is available, it looks like backport to 6.4.x is pretty safe. Is it possible?
Comment 4 Rizal Muttaqin 2020-01-15 07:53:17 UTC
(In reply to Boaz Dodin from comment #3)
> As 32px is not the default size and fallback is available, it looks like
> backport to 6.4.x is pretty safe. Is it possible?

The patch is coming https://gerrit.libreoffice.org/c/core/+/86808
Comment 5 Boaz Dodin 2020-01-15 07:55:25 UTC
(In reply to Rizal Muttaqin from comment #4)
> (In reply to Boaz Dodin from comment #3)
> > As 32px is not the default size and fallback is available, it looks like
> > backport to 6.4.x is pretty safe. Is it possible?
> 
> The patch is coming https://gerrit.libreoffice.org/c/core/+/86808

Thank you!
Comment 6 Commit Notification 2020-01-21 11:00:40 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b436848a515dbc1c6f5b2fee8a4ab184a348b950

Sifr: Add more 32px extra large icons (tdf#129846)

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-01-21 15:40:58 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9cd35a2896a1557a6757069d6defe0dbd0cbe2c1

Sifr: Add more 32px extra large icons (tdf#129846)

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-01-22 22:12:13 UTC
rizmut committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/54368ea4b13bfb1437459d3a3b5bc009d263079b

Breeze & Sifr: tdf#128849 & Sifr: tdf#129846

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.