Download it now!
Bug 129850 - CRASH: Inserting table (gtk3)
Summary: CRASH: Inserting table (gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0
Keywords: bibisected, bisected, regression
: 129872 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-07 09:37 UTC by Xisco Faulí
Modified: 2020-01-08 21:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-01-07 09:37:01 UTC
Steps to reproduce:
1. Open Writer
2. Insert a table

-> Crash

Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: bf540873f5e258452fed5006f65a403c95e7872a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-01-07 09:38:08 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=40fe5b93bc0838e04b46bfc7942d1ee6a2482ce0

author	Caolán McNamara <caolanm@redhat.com>	2020-01-02 14:45:32 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-01-06 16:44:21 +0100
commit	40fe5b93bc0838e04b46bfc7942d1ee6a2482ce0 (patch)
tree	151814d0863c9912d18722732beb13b1e22e0ff1
parent	d1133d71a6109d1999121fd6a91573d12dc4852b (diff)
weld AreaPropertyPanel

Bisected with: bibisect-linux64-6.5

Adding Cc: to Caolán McNamara
Comment 2 Commit Notification 2020-01-07 15:44:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c854c4e89b0842d1c138c91f697a9ac894c2becc

Resolves: tdf#129850 crash inserting table

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2020-01-08 10:00:02 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 4f6d95ead1286748810e937c7672de08b8b39a38
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 4 Julien Nabet 2020-01-08 14:04:27 UTC
*** Bug 129872 has been marked as a duplicate of this bug. ***
Comment 5 Roman Kuznetsov 2020-01-08 16:08:45 UTC
(In reply to Julien Nabet from comment #4)
> *** Bug 129872 has been marked as a duplicate of this bug. ***

Possible it are two different crashes. I still repro my original bug in build from today 08 January 2020 on Windows. I need updated 6.5 bisect repo for windows
Comment 6 Roman Kuznetsov 2020-01-08 21:12:17 UTC
(In reply to Roman Kuznetsov from comment #5)
> (In reply to Julien Nabet from comment #4)
> > *** Bug 129872 has been marked as a duplicate of this bug. ***
> 
> Possible it are two different crashes. I still repro my original bug in
> build from today 08 January 2020 on Windows. I need updated 6.5 bisect repo
> for windows

Just for record: it was problem with installing daily builds in to the same path using SiGUI. Interesting that deleting of user profile didn't resolve the problem. 
I have no crash on Windows after installing current build into full clean path.