Bug 129859 - FILEOPEN XLSX The legend shows deleted legend entries too in pie charts
Summary: FILEOPEN XLSX The legend shows deleted legend entries too in pie charts
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Tünde Tóth
URL:
Whiteboard: target:6.5.0
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-01-07 12:57 UTC by NISZ LibreOffice Team
Modified: 2020-02-19 14:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel (20.08 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-01-07 12:58 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc (80.25 KB, image/png)
2020-01-07 12:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-01-07 12:57:14 UTC
Description:
The legend shows deleted legend entry too in Excel worksheet opened in LibreOffice 6.5.0.0.alpha0+ (x64).  

Steps to Reproduce:
    1. Create an XLSX spreadsheet in Microsoft Excel.
    2. Insert a Pie Chart.
    3. Delete the second legend entry.
    4. Save the file, and open it with LibreOffice 6.5.0.0.alpha0+ (x64).
    5. View the attached screenshot.
    6. Notice, that in LibreOffice Calc the deleted legend entry is visible. 

Actual Results:
The deleted legend entry is visible. 

Expected Results:
The deleted legend entry shouldn’t be visible.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2020-01-07 12:58:33 UTC
Created attachment 156988 [details]
Example file from Excel
Comment 2 NISZ LibreOffice Team 2020-01-07 12:59:05 UTC
Created attachment 156989 [details]
Screenshot of the original document side by side in Excel and Calc
Comment 3 László Németh 2020-01-10 10:09:35 UTC
@Gábor, Tünde: in fact, this is a duplicate of Bug 129858. I suggest to modify this issue to FILEOPEN/FILESAVE ODS or FILEOPEN DOCX(!), according to the recent solution, the UNO API extension. Code pointer for fixing the DOCX documents with embedded charts:

commit 7869b3d6e4b24a0567ad2e492038d74c03b06b7d
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Fri Dec 7 23:28:28 2018 +0100

    related tdf#51671, store new "hide legend" feature also in ODF
Comment 4 László Németh 2020-01-10 13:15:10 UTC
(In reply to László Németh from comment #3)
> @Gábor, Tünde: in fact, this is a duplicate of Bug 129858. 

Sorry, it's not the same.
Comment 5 Commit Notification 2020-01-10 13:22:25 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6e847aa817999ab18acd534f9e6a86685bb268fc

tdf#129859 XLSX import: don't show deleted legend entries

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-01-17 12:36:33 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: cc36c115004cb75037b0e4fdadff09035f765cd5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Tünde Tóth, thanks for fixing this issue!!