Download it now!
Bug 129860 - Print dialog is too large in Writer and Print/Cancel buttons are covered by the macOS dock
Summary: Print dialog is too large in Writer and Print/Cancel buttons are covered by t...
Status: RESOLVED DUPLICATE of bug 127782
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-07 13:21 UTC by telemako
Modified: 2020-01-14 09:14 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
LO Version 6.3.4.2 (219.52 KB, image/png)
2020-01-12 21:00 UTC, telemako
Details
UI Bug (1022.24 KB, image/png)
2020-01-12 21:01 UTC, telemako
Details
By changing to "Layout" (or others) instead of "Libreoffice" the dialog box gets smaller and the Cancel/Print buttons are visible. (939.23 KB, image/png)
2020-01-12 21:04 UTC, telemako
Details

Note You need to log in before you can comment on or make changes to this bug.
Description telemako 2020-01-07 13:21:39 UTC
Description:
The print dialog opening up in Writer (Menu: File/Print) is too large and the Print/Cancel buttons are covered by the MacOS dock. The only way to click on the dialog buttons is by either temporarily hiding the MacOS dock or choosing another entry from dropdown menu in the print dialog box (e.g. "Layout" or else, instead of the default "Libreoffice"). This happens Libreoffice 6.3 onwards on Macbook Pro 13" Retina Display, MacOS 10.15.2. This behavior seems only to happen in Writer but not in Calc, Impress. Workaround: Reverting back to Libreoffice V6.2.8.2 which is not affected.

Steps to Reproduce:
1. Open Writer and (blank) document
2. Select "File" in the menu
3. Select "Print"

Actual Results:
The Print dialog is too large, the buttons hidden by the MacOS dock.

Expected Results:
The Print dialog should be smaller (or resizable) and the buttons visible (like in V6.2.x and previous).


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 steve -_- 2020-01-12 20:37:36 UTC
Could you update to LO 6.3.4.2 and if the problem persists, attach a screenshot of this problem. After that set the bug back to "Unconfirmed". Thanks.

Unable to reproduce on macOS 10.15.2, LO 6.3.4.2.
Comment 2 telemako 2020-01-12 21:00:22 UTC
Created attachment 157091 [details]
LO Version 6.3.4.2
Comment 3 telemako 2020-01-12 21:01:59 UTC
Created attachment 157092 [details]
UI Bug
Comment 4 telemako 2020-01-12 21:04:08 UTC
Created attachment 157093 [details]
By changing to "Layout" (or others) instead of "Libreoffice" the dialog box gets smaller and the Cancel/Print buttons are visible.
Comment 5 telemako 2020-01-12 21:06:11 UTC
(In reply to steve -_- from comment #1)
> Could you update to LO 6.3.4.2 and if the problem persists, attach a
> screenshot of this problem. After that set the bug back to "Unconfirmed".
> Thanks.
> 
> Unable to reproduce on macOS 10.15.2, LO 6.3.4.2.

I did, see my comments above. Thanks.
Comment 6 steve -_- 2020-01-12 22:51:27 UTC
Thanks. Can you share exact screensize and resolution of the mac you are using.
Comment 7 telemako 2020-01-13 06:58:44 UTC
(In reply to steve -_- from comment #6)
> Thanks. Can you share exact screensize and resolution of the mac you are
> using.

It's a Macbook Pro with a 13.3" Retina Display (Resolution 2560 x 1600).
Comment 8 steve -_- 2020-01-13 09:30:23 UTC
Thanks. After investigating further it seems this bug here is a duplicate of an existing bug. Thus updating the status accordingly.

*** This bug has been marked as a duplicate of bug 127782 ***
Comment 9 Alex Thurgood 2020-01-14 09:14:35 UTC
Confirming with

Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
Threads CPU : 4; OS : Mac OS X 10.15.2; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

MacMini : 10.15.2
Output Display : 1920 x 1080