Download it now!
Bug 129904 - Help button in Options - LibreOffice does not show relevant pages
Summary: Help button in Options - LibreOffice does not show relevant pages
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0
Keywords: bibisected, bisected, regression
: 129415 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-09 09:19 UTC by sdc.blanco
Modified: 2020-01-20 12:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-01-09 09:19:26 UTC
1. Tools>Options (Alt-F12) - Libreoffice - (select any of the subcategories)
2. click: Help

Problem 1:  (for all subcategories)

Actual:    Goes to generic help page
Expected:  relevant help page.

Works as expected in LO 6.3.4.2

Problem 2:  Click Help a second time (and onward). 

Actual:  Goes to help for "Advanced" tab

This problem may be related to bug #129745 	

(Note: if Advanced was selected the first time, then help still goes to the generic page - i.e., Problem 1).

Works as expected in LO 6.3.4.2
Comment 1 Xisco Faulí 2020-01-09 10:22:53 UTC
After

https://cgit.freedesktop.org/libreoffice/core/commit/?id=94d6fa11d086187b82adf9aa596e0f334827e095

author	Caolán McNamara <caolanm@redhat.com>	2019-09-17 12:50:05 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-09-20 21:20:51 +0200
commit	94d6fa11d086187b82adf9aa596e0f334827e095 (patch)
tree	4a44af903b2572efe89ae5e8aa67bb092644e038
parent	3c84b18f4f0fe4058de60b1c62149275ed858b79 (diff)
weld OfaTreeOptionsDialog

The Advanced help page was opened instead of the current one ( e.g. View )

Adding Cc: to Caolán McNamara
Comment 2 Xisco Faulí 2020-01-09 10:40:21 UTC
Later on, it changed from opening the Advanced help page to the main component page in

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d4c22030d7c83de6f1835cdb5d891c2d563c34fd

author	Caolán McNamara <caolanm@redhat.com>	2019-12-02 12:56:43 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-02 21:17:59 +0100
commit	d4c22030d7c83de6f1835cdb5d891c2d563c34fd (patch)
tree	6b8f661797ff6da3d9cc6f6188643940b1497ae6
parent	260c50e252abf6f4d523d9ed1c11fa407277087f (diff)
tdf#129068 try dialog content area help before dialog itself
Comment 3 Commit Notification 2020-01-10 20:55:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e2737ee24afac3254d7cb533b5c7d42d136bf7b4

Resolves: tdf#129904 use the current page as the page for help

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2020-01-10 21:16:32 UTC
fixed in master, backport to 6-4 in gerrit
Comment 5 Commit Notification 2020-01-12 04:06:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/52ac526a61c1a26bb9dbf995f4af02c9469b8cf6

Resolves: tdf#129904 use the current page as the page for help

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-01-13 09:29:01 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: d5047c4a1cbae1cb2b57ed435ecd63e6817506d3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 7 Commit Notification 2020-01-13 18:11:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-0":

https://git.libreoffice.org/core/commit/6b3e268c9d21b911f14bab8ef95f69cf171a137c

Resolves: tdf#129904 use the current page as the page for help

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-01-20 12:05:51 UTC
*** Bug 129415 has been marked as a duplicate of this bug. ***