Bug 129912 - Cannot open DOC - regression
Summary: Cannot open DOC - regression
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.1 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.1
Keywords: bibisected, bisected, filter:doc, haveBacktrace, regression
: 130558 (view as bug list)
Depends on:
Blocks: DOC-Opening
  Show dependency treegraph
 
Reported: 2020-01-09 17:23 UTC by Timur
Modified: 2020-02-11 13:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bt at random (19.05 KB, text/plain)
2020-01-09 20:21 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2020-01-09 17:23:54 UTC
With 6.5+ cannot open DOC attachment 73104 [details] from bug 105035 and bug 59426.
Not seen in 6.3. Test Windows. Regression.
Comment 1 Julien Nabet 2020-01-09 20:21:25 UTC
Created attachment 157046 [details]
bt at random

On pc Debian x86-64 with master sources updated today, I could reproduce this.

I attached a bt taken at random once there were no more console logs.

bt seems to show a never ending loop in layout management.
Comment 2 Drew Jensen 2020-01-09 20:24:17 UTC
Same in Ubuntu 18.04.1 and LO 6.4 RC1
With system monitor running it simply runs the system out of resources real memory and virtual.
Comment 3 Roman Kuznetsov 2020-01-11 13:11:55 UTC
I bisected it, result sha hash is

a991ad93dcd6807d0eacd11a50c2ae43a2cfb882


https://gerrit.libreoffice.org/c/core/+/81370

Add CC to: Jan-Marek Glogowski
Comment 4 Commit Notification 2020-02-05 01:39:19 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7d886eec953efa593708db9560d0e69ac12c99cf

tdf#129912 correctly stop unstyled footnote parsing

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Timur 2020-02-06 12:18:54 UTC
Can be open now, 9 pages as in Word. Thanks JM.
Comment 6 Xisco Faulí 2020-02-07 16:53:09 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: c81c383be787ec5f9acbca51f75ea5b28b63c63a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Commit Notification 2020-02-10 11:25:41 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a4567fb085ae313f514d2001b9e52499c9887a56

tdf#129912 correctly stop unstyled footnote parsing

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-02-10 14:40:12 UTC
*** Bug 130558 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2020-02-11 09:54:49 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-1":

https://git.libreoffice.org/core/commit/2d6f3e8a69e7675361dce68ffe670b7673b1df19

tdf#129912 correctly stop unstyled footnote parsing

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.