Download it now!
Bug 129926 - Hyperlink drag-and-drop crashes Writer when dropped onto itself. (kde)
Summary: Hyperlink drag-and-drop crashes Writer when dropped onto itself. (kde)
Status: RESOLVED DUPLICATE of bug 129809
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2020-01-10 13:39 UTC by Stephan van den Akker
Modified: 2020-01-23 12:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document containing a hyperlink (8.27 KB, application/vnd.oasis.opendocument.text)
2020-01-10 13:51 UTC, Stephan van den Akker
Details
backtrace from the crash (22.81 KB, text/x-log)
2020-01-19 21:59 UTC, Stephan van den Akker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan van den Akker 2020-01-10 13:39:02 UTC
Description:
When trying to select part of a hyperlink text in Writer using the mouse it immediately switches to drag-and-drop mode for the complete hyperlink.

If you then release the mouse button Writer while the mouse pointer still hovers over the hyperlink it tries to drop the hyperlink into itself.

Steps to Reproduce:
1: Load the sample document;
2: Drag the mouse pointer over part of the hyperlink;
3: Release the mouse button while the mouse pointer still hovers over the hyperlink.



Actual Results:
Writer crashes.

Expected Results:
No crash. No switch to drag-and-drop?


Reproducible: Always


User Profile Reset: No



Additional Info:
No crash:
- on similar actions in Calc;
- when the hyperlink gets dropped outside itself;
- when another hyperlink gets dropped in the same place.

Observed in Opensuse Tumbleweed:

Version: 6.3.3.2.0+
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

Version: 6.5.0.0.alpha0+
Build ID: 16f8807a9255359da53e980185591e356166e414
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

NOT Observed in:

Versie: 6.0.7.3 (x64)
Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU-threads: 4; Besturingssysteem: Windows 10.0; UI-render: GL; 
Locale: nl-NL (nl_NL); Calc: group
Comment 1 Stephan van den Akker 2020-01-10 13:51:59 UTC
Created attachment 157067 [details]
Sample document containing a hyperlink
Comment 2 Julien Nabet 2020-01-11 13:12:15 UTC
In 3., you indicate "Release the mouse button".
At which moment do you click it (without released it)?
Comment 3 Stephan van den Akker 2020-01-13 20:48:13 UTC
A clarification.

Steps to Reproduce:
1: Load the sample document;
2: Click somewhere on the hyperlink and drag the mouse pointer to select a part of the hyperlink;
3: Release the mouse button while the mouse pointer still hovers over the hyperlink.
Comment 4 Julien Nabet 2020-01-18 10:46:03 UTC
On pc Debian x86-64 with master sources updated today + kf5 rendering, I don't reproduce this.
Perhaps I missed something.
Anyway, a backtrace could help here (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 5 Stephan van den Akker 2020-01-19 21:59:26 UTC
Created attachment 157256 [details]
backtrace from the crash
Comment 6 Julien Nabet 2020-01-20 20:02:51 UTC
According to the bt, it seems QT/KDE related.

For the test, could you launch a terminal and try this:
export SAL_USE_VCLPLUGIN=gen
soffice

then give it a new try?
Comment 7 Stephan van den Akker 2020-01-21 21:42:07 UTC
No crash after:

export SAL_USE_VCLPLUGIN=gen

Version: 6.5.0.0.alpha0+
Build ID: 01a3a7cee2dc680910f4ddec004724b89a81099b
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: x11; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 8 Julien Nabet 2020-01-22 21:50:49 UTC
Thank you Stephan for your feedback.

Michael: any idea about this kde specific bug?
Comment 9 Michael Weghorn 2020-01-23 12:38:40 UTC
This seems to be the same issue as described in bug 129809. (The backtrace is also comparable.)

*** This bug has been marked as a duplicate of bug 129809 ***