Download it now!
Bug 129929 - Skia: LibreOffice doesn't start
Summary: Skia: LibreOffice doesn't start
Status: RESOLVED DUPLICATE of bug 129546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-01-10 14:41 UTC by Roman Kuznetsov
Modified: 2020-01-15 09:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-01-10 14:41:04 UTC
Description:
Skia: LibreOffice doesn't start when Skia enabled on Windows 10. I have 

DriverVersion: 10.18.10.4358
DriverDate: 12-21-2015
DeviceID: PCI\VEN_8086&DEV_0166&SUBSYS_21F717AA&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0166
AdapterSubsysID: 0x21f717aa
DeviceKey: System\CurrentControlSet\Control\Video\{2FBAC3F2-E9C8-11E9-AC1D-806E6F6E6963}\0000
DeviceString: Intel(R) HD Graphics 4000

Yes, I used "Ignore Skia blacklist". But some time ago LO started even with that enabled option on this machine

Steps to Reproduce:
1. Enable Skia, enable "Ignore Skia blacklist" option
2. Restart LibreOffice
3. LO doesn't start

Actual Results:
LO doesn't start

Expected Results:
LO starts


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.5.0.0.alpha0+ (x64)
ID сборки: b6295e4a1b7735c148174f44f6d28221f4f52302
Потоков ЦП: 4; ОС:Windows 10.0 Build 18362; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 1 Julien Nabet 2020-01-10 15:56:32 UTC
I noticed DriverDate: 12-21-2015, did you try to upgrade your graphic card driver?
Comment 2 V Stuart Foote 2020-01-10 16:13:29 UTC
Can not reproduce, same build
on Windows 10 Home 64-bit en-US with Intel HD Graphics 620

Version: 6.5.0.0.alpha0+ (x64)
Build ID: b6295e4a1b7735c148174f44f6d28221f4f52302
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

@Roman, could be a driver issue. Current is the .5069 build:

https://downloadcenter.intel.com/download/28799/Intel-Graphics-Driver-for-Windows-15-33-?product=81499
Comment 3 Luboš Luňák 2020-01-12 15:52:29 UTC
If "LO doesn't start", then what does it do?

Ignoring Skia blacklist is currently irrelevant, as it's not implemented yet.
Comment 4 Roman Kuznetsov 2020-01-12 17:12:06 UTC
(In reply to Luboš Luňák from comment #3)
> If "LO doesn't start", then what does it do?

It does nothing. I don't see soffice process even in the list of Windows task manager.

(In reply to Luboš Luňák from comment #3)
> Ignoring Skia blacklist is currently irrelevant, as it's not implemented yet.

If I don't check "Ignore Skia blacklist" option then Skia doesn't activat after LO restarting
Comment 5 QA Administrators 2020-01-13 03:35:52 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2020-01-13 10:13:34 UTC
(In reply to V Stuart Foote from comment #2)
> Can not reproduce, same build
> on Windows 10 Home 64-bit en-US with Intel HD Graphics 620
>
> ...
> 
> @Roman, could be a driver issue. Current is the .5069 build:

I updated Intel video driver to latest version from its site and now I have here

DriverVersion: 10.18.10.5100
DriverDate: 10-31-2019
DeviceID: PCI\VEN_8086&DEV_0166&SUBSYS_21F717AA&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0166
AdapterSubsysID: 0x21f717aa
DeviceKey: System\CurrentControlSet\Control\Video\{2FBAC3F2-E9C8-11E9-AC1D-806E6F6E6963}\0000
DeviceString: Intel(R) HD Graphics 4000

LO still doesn't start
Comment 7 Luboš Luňák 2020-01-13 11:48:07 UTC
(In reply to Roman Kuznetsov from comment #4)
> It does nothing. I don't see soffice process even in the list of Windows
> task manager.

Technically, the only way a program "does nothing" is when you do not even launch it. If you launch it, it does to have something, even if that would be just exiting or crashing immediately.

Please try to run it in a debugger and see what happens (if you do not have enough time to do Debug->Attach to Process in Visual Studio, then https://pastebin.com/vyAsgxRa should help there).

Another way to possibly get some information might be to run it as 'SAL_LOG=+INFO soffice ; echo "Exit Code: $?" '.
Comment 8 Luboš Luňák 2020-01-14 11:18:41 UTC
This may possibly be a duplicate of bug #129546.
Comment 9 Roman Kuznetsov 2020-01-15 09:09:19 UTC
problem is gone today after fix for tdf#129546

Версия: 6.5.0.0.alpha0+ (x64)
ID сборки: 147af9e2cf7f937ed83ab00574b6a418a2cb629e
Потоков ЦП: 4; ОС:Windows 10.0 Build 18362; Отрисовка ИП: Skia/Raster; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

Really, I think it's a duplicate of tdf#129546

Thanks, Luboš.

*** This bug has been marked as a duplicate of bug 129546 ***