Bug 129960 - Print range for sheet 13 or higher not saved to ODS format, if linked data is used
Summary: Print range for sheet 13 or higher not saved to ODS format, if linked data is...
Status: RESOLVED DUPLICATE of bug 51022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Range
  Show dependency treegraph
 
Reported: 2020-01-12 22:02 UTC by Tomasz
Modified: 2021-07-29 14:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer file made in 7.3 master per instructions (10.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-07-29 14:45 UTC, NISZ LibreOffice Team
Details
The bug in LO 7.2 bibisect repo (139.49 KB, image/png)
2021-07-29 14:49 UTC, NISZ LibreOffice Team
Details
Sheet 13 in the fixed version (144.73 KB, image/png)
2021-07-29 14:51 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz 2020-01-12 22:02:33 UTC
Description:
In case of documents that contain linked data (things like ='file:///C:/path/file.ods'#$Sheet1.A1) option 'Print' produces empty prints for sheets 13 or higher. Print does work fine for sheet 1 up to sheet 12. 
It happens for Linux and Windows.


Steps to Reproduce:
I'm using Polish version of LO.
1. Create Calc document and in Sheet1 fill cells A1 to A13 with values 1 to 13.
2. Save the file and close the app.
3. Create another calc document and add 12 sheets so that there are 13 sheets all together. 
4. Go back to first sheet and in cell A1 enter ='file:///C:/path/first_file.ods'#$Sheet1.A1 
5. In second sheet in cell A1 enter ='file:///C:/path/first_file.ods'#$Sheet1.A2. Repeat the process for remaining sheets replacing A2 with A3, A4,... 
6. Save second file and close the app
7. Reopen second file, allow loading external content, go to sheet 13 and hit "Print Preview" <- bug there is nothing in the preview (in my case "Empty print range" but in Polish "Pusty zakres wydruku"). Also Print doesn't print anything

Actual Results:
Empty 'Pring preview', empty paper sheet

Expected Results:
A13 printed on paper


Reproducible: Always


User Profile Reset: Yes



Additional Info:
If second file is saved in Excel file format then 'Print preview' is working correctly

Wersja: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
Wątki CPU: 8; OS:Windows 10.0; UI render:domyślny; VCL: win; 
Ustawienia regionalne: pl-PL (pl_PL); Język interfejsu: pl-PL
Calc: threaded
Comment 1 Buovjaga 2020-05-01 19:08:00 UTC
Bibisected with win32-5.0 to https://git.libreoffice.org/core/+/bfa4494560884635a03c4db89588a118f9a2be0b%5E!/

loplugin:simplifybool

Adding Cc: to Stephan Bergmann

Note: having an example attachment would not be of use. The second file needs to be created anew every time (as I did with bibisecting). However, there is no need to paste anything into sheets 1-12. Just create enough sheets and use sheet 13.
Comment 2 Stephan Bergmann 2020-05-04 12:23:55 UTC
(In reply to Buovjaga from comment #1)
> Bibisected with win32-5.0 to
> https://git.libreoffice.org/core/+/
> bfa4494560884635a03c4db89588a118f9a2be0b%5E!/
> 
> loplugin:simplifybool

So that's apparently win32-5.0 commit

  commit 3f260185ffe126f045f3b4d7776c17e591ce2228
  Author: Norbert Thiebaud <nthiebaud@gmail.com>
  Date:   Mon Jun 1 16:05:57 2015 -0500
  
      source sha:bfa4494560884635a03c4db89588a118f9a2be0b
      
      source sha:bfa4494560884635a03c4db89588a118f9a2be0b

However, if I check out its predecessor and follow the below reproducer recipe, it also shows the unexpected "Print Range Empty".  Buovjaga, can you please verify that you bibisected correctly?

> Note: having an example attachment would not be of use. The second file
> needs to be created anew every time (as I did with bibisecting). However,
> there is no need to paste anything into sheets 1-12. Just create enough
> sheets and use sheet 13.
Comment 3 Buovjaga 2020-05-04 14:37:11 UTC
Blah, now I can't reproduce the issue with latest master on Windows or Linux!

Tomasz: can you please test with a fresh build: https://dev-builds.libreoffice.org/daily/master/current.html Win-x86_64@tb77-TDF?

I also realised my win32-5.0 result was bogus after retesting the first bad commit.

Stephan on IRC tells me he can reproduce the problem on Linux master, so I don't know which way is up anymore.
Comment 4 QA Administrators 2020-11-01 04:20:14 UTC Comment hidden (obsolete)
Comment 5 Tomasz 2020-11-02 07:31:04 UTC
Hi Guys,

I confirm that I can't reproduce the issue with 7.0.2.2 on Windows!
So the problem is gone for me but was it fixed ? :)
Comment 6 Buovjaga 2020-11-02 14:36:19 UTC
I can still reproduce with Linux master, unfortunately

Arch Linux 64-bit
Version: 7.1.0.0.alpha1+
Build ID: 2764c334c3b9cf428e4e7ab0c28ce6a34036fa77
CPU threads: 8; OS: Linux 5.9; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 2 November 2020
Comment 7 NISZ LibreOffice Team 2021-07-29 14:45:36 UTC
Created attachment 173948 [details]
Reproducer file made in 7.3 master per instructions
Comment 8 NISZ LibreOffice Team 2021-07-29 14:49:33 UTC
Created attachment 173949 [details]
The bug in LO 7.2 bibisect repo

How sheet 13 (what really mattered is that it was the last one) looked in print preview in the last bad version.
Comment 9 NISZ LibreOffice Team 2021-07-29 14:51:26 UTC
Created attachment 173950 [details]
Sheet 13 in the fixed version

Looks good now, since:

https://git.libreoffice.org/core/+/88476a6f89f2908fc8083dbbb53391b75192c783%5E%21
Comment 10 NISZ LibreOffice Team 2021-07-29 14:52:04 UTC
Thanks Attila for fixing this one too :)

*** This bug has been marked as a duplicate of bug 51022 ***