Download it now!
Bug 129995 - Chart wizard steps panel is black (gtk3)
Summary: Chart wizard steps panel is black (gtk3)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2020-01-14 12:42 UTC by Markus Elfring
Modified: 2020-06-21 19:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Excerpt of a screenshot from a questionable chart wizard display (58.55 KB, image/png)
2020-01-14 12:42 UTC, Markus Elfring
Details
how it looks for me (121.77 KB, image/png)
2020-06-21 15:41 UTC, Caolán McNamara
Details
stand alone GtkAssistant demo (1.65 KB, application/x-designer)
2020-06-21 15:58 UTC, Caolán McNamara
Details
Excerpt of a screenshot from a stand-alone GtkAssistant demo (7.28 KB, image/png)
2020-06-21 18:06 UTC, Markus Elfring
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Elfring 2020-01-14 12:42:40 UTC
Created attachment 157146 [details]
Excerpt of a screenshot from a questionable chart wizard display

I have tried the provided functionality out again together with the software combination “LibreOffice Calc 6.4.0.1-875.2”.
Build-ID: 40(Build:1)
CPU-Threads: 4; BS: Linux 5.4; UI-Render: Standard; VCL: gtk3

Now I wonder about the unreadable display for configuration steps in the chart wizard.
https://help.libreoffice.org/6.4/en-GB/text/schart/01/wiz_chart_type.html

How would you like to fix this widget?
Comment 1 Xisco Faulí 2020-05-11 08:55:29 UTC
hello Markus,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Markus Elfring 2020-05-11 12:00:10 UTC
(In reply to Xisco Faulí from comment #1)
I observe a questionable chart wizard display also together with the software combination “LibreOffice Calc 6.4.3.2-904.3”.
Comment 3 Xisco Faulí 2020-05-11 14:25:54 UTC
Could you please paste the info from Help - about LibreOffice ? OTOH, do you reproduce it if you launch LibreOffice from commandline with 'SAL_USE_VCLPLUGIN=gen' ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 4 Markus Elfring 2020-05-11 14:45:13 UTC
(In reply to Xisco Faulí from comment #3)
> OTOH, do you reproduce it if you launch LibreOffice from commandline with 'SAL_USE_VCLPLUGIN=gen' ?

No.

The display for configuration steps in the chart wizard looks acceptable with this execution parameter.
Comment 5 Xisco Faulí 2020-05-11 14:47:08 UTC
(In reply to Markus Elfring from comment #4)
> (In reply to Xisco Faulí from comment #3)
> > OTOH, do you reproduce it if you launch LibreOffice from commandline with 'SAL_USE_VCLPLUGIN=gen' ?
> 
> No.
> 
> The display for configuration steps in the chart wizard looks acceptable
> with this execution parameter.

Nice, and what about the help - about LibreOffice ?
Comment 6 Markus Elfring 2020-05-11 14:56:04 UTC
(In reply to Xisco Faulí from comment #5)
Please take information from my initial bug report better into account.
Comment 7 Xisco Faulí 2020-05-11 15:11:55 UTC
(In reply to Markus Elfring from comment #6)
> (In reply to Xisco Faulí from comment #5)
> Please take information from my initial bug report better into account.

you updated it based on comment 2.
I just want to know, is it gtk3 or kde5 ? Anyway, please paste it
Comment 8 Markus Elfring 2020-05-11 15:43:17 UTC
(In reply to Xisco Faulí from comment #7)
* The display for configuration steps in the chart wizard was broken for the GTK3-interface.

* The display looks acceptable with the execution parameter “SAL_USE_VCLPLUGIN=kf5”.
Comment 9 Buovjaga 2020-06-20 15:50:37 UTC
Bibisected with Linux 6.4 repo to https://git.libreoffice.org/core/+/d661cb17610af93b1607025284f23187c6d2fc06%5E!/
weld chart CreationWizard

Adding Cc: to Caolán McNamara
Comment 10 Caolán McNamara 2020-06-21 15:41:52 UTC
Created attachment 162261 [details]
how it looks for me
Comment 11 Caolán McNamara 2020-06-21 15:46:28 UTC
what gtk theme is in use? (e.e. gnome-tweaks, appearance, themes, application)
Comment 12 Caolán McNamara 2020-06-21 15:58:22 UTC
Created attachment 162262 [details]
stand alone GtkAssistant demo

with glade-previewer installed, (part of glade) does...

glade-previewer -f standalonedemo.ui

result in an assistant with the same problem ?
Comment 13 Buovjaga 2020-06-21 17:14:50 UTC
(In reply to Caolán McNamara from comment #11)
> what gtk theme is in use? (e.e. gnome-tweaks, appearance, themes,
> application)

I was using breeze-gtk. I changed to the default theme and the problem is gone. Should I report the issue to breeze-gtk?

The source code is here: https://invent.kde.org/plasma/breeze-gtk
The bugs live here: https://bugs.kde.org/buglist.cgi?component=gtk%20theme&order=changeddate%2Cpriority%2Cbug_severity&product=Breeze&query_format=advanced&resolution=---
Comment 14 Markus Elfring 2020-06-21 18:06:26 UTC
Created attachment 162264 [details]
Excerpt of a screenshot from a stand-alone GtkAssistant demo

(In reply to Caolán McNamara from comment #12)
Do you find this test display interesting?
Comment 15 Caolán McNamara 2020-06-21 18:50:40 UTC
yeah (wrt comment #14) the standalone demo shows the same problem of black text on a black background in that theme so IMO its not a bug on our side then.

wrt comment #13, yes, its probably worth filing a bug against the upstream for that theme. Using the standalone .ui as the reproducer when filing upstream seems a good idea. No idea if the black bg is intentional but if it is then presumably the text color shouldn't be black too.
Comment 16 Buovjaga 2020-06-21 19:10:50 UTC
Upstream bug filed as https://bugs.kde.org/show_bug.cgi?id=423331